aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-18 23:54:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-18 23:54:08 +0000
commitc2b78f87d9e220f688810374e96a536f2d71e1fc (patch)
tree72b0b49c24d9f27096c9ee6b2a5911c50105195b /package/openssl
parent970918cc4540dcc359c6654a4934e9f9d29a13af (diff)
downloadupstream-c2b78f87d9e220f688810374e96a536f2d71e1fc.tar.gz
upstream-c2b78f87d9e220f688810374e96a536f2d71e1fc.tar.bz2
upstream-c2b78f87d9e220f688810374e96a536f2d71e1fc.zip
openssl does not compile with uml and arch x86_64
Hi, I found that openssl did not compile on the uml target under x86_64. The attached patch should correct this and is working for me. Is this the right way to do it? thanks, Thomas SVN-Revision: 32443
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index a696dd7cd4..7043aeeb18 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -82,11 +82,16 @@ else
OPENSSL_OPTIONS += no-engines
endif
-OPENSSL_OPTIONS += no-perlasm
+ifeq ($(CONFIG_x86_64),y)
+ OPENSSL_TARGET:=linux-x86_64
+else
+ OPENSSL_TARGET:=linux-openwrt
+ OPENSSL_OPTIONS+=no-perlasm no-sse2
+endif
define Build/Configure
(cd $(PKG_BUILD_DIR); \
- ./Configure linux-openwrt \
+ ./Configure $(OPENSSL_TARGET) \
--prefix=/usr \
--openssldir=/etc/ssl \
$(TARGET_CPPFLAGS) \