aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:46:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:46:01 +0000
commitec4bcec062e50e9f2ecdc89daa5a9b1353b49a4b (patch)
tree06820eb574a89643f6f84edddbe0a9ae8f0dedd9 /package/openssl
parent13e24e7ed30216dd6cb1b38f276b033afc08e960 (diff)
downloadupstream-ec4bcec062e50e9f2ecdc89daa5a9b1353b49a4b.tar.gz
upstream-ec4bcec062e50e9f2ecdc89daa5a9b1353b49a4b.tar.bz2
upstream-ec4bcec062e50e9f2ecdc89daa5a9b1353b49a4b.zip
openssl 1.0.1 update patch
This patch updates openssl to 1.0.1 and refreshes all patches. Signed-off-by: Peter Wagner <tripolar@gmx.at> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30984 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile5
-rw-r--r--package/openssl/patches/110-optimize-for-size.patch6
-rw-r--r--package/openssl/patches/140-makefile-dirs.patch6
-rw-r--r--package/openssl/patches/150-no_engines.patch2
-rw-r--r--package/openssl/patches/160-disable_doc_tests.patch16
-rw-r--r--package/openssl/patches/190-remove_timestamp_check.patch6
-rw-r--r--package/openssl/patches/200-etrax_support.patch2
7 files changed, 22 insertions, 21 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 22e85ec7a8..424bd39625 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
-PKG_VERSION:=1.0.0h
+PKG_VERSION:=1.0.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
ftp://ftp.webmonster.de/pub/openssl/source/ \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=a5bc483c570f2ac3758ce5c19b667fab
+PKG_MD5SUM:=134f168bc2a8333f19f81d684841710b
PKG_BUILD_DEPENDS:=ocf-crypto-headers
PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
@@ -130,6 +130,7 @@ define Build/Compile
$(OPENSSL_MAKEFLAGS) \
do_linux-shared
$(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
$(OPENSSL_MAKEFLAGS) \
install
diff --git a/package/openssl/patches/110-optimize-for-size.patch b/package/openssl/patches/110-optimize-for-size.patch
index 13c5a8c6cc..c0160a3f19 100644
--- a/package/openssl/patches/110-optimize-for-size.patch
+++ b/package/openssl/patches/110-optimize-for-size.patch
@@ -1,11 +1,11 @@
--- a/Configure
+++ b/Configure
-@@ -379,6 +379,8 @@ my %table=(
+@@ -400,6 +400,8 @@ my %table=(
"linux-alpha+bwx-gcc","gcc:-O3 -DL_ENDIAN -DTERMIO::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:${alpha_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
+# OpenWrt targets
+"linux-openwrt","gcc:-DTERMIO \$(OPENWRT_OPTIMIZATION_FLAGS) -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- #### *BSD [do see comment about ${BSDthreads} above!]
- "BSD-generic32","gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ # Android: linux-* but without -DTERMIO and pointers to headers and libs.
+ "android","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
diff --git a/package/openssl/patches/140-makefile-dirs.patch b/package/openssl/patches/140-makefile-dirs.patch
index c252be9b89..b51ca28b62 100644
--- a/package/openssl/patches/140-makefile-dirs.patch
+++ b/package/openssl/patches/140-makefile-dirs.patch
@@ -1,8 +1,8 @@
--- a/Makefile.org
+++ b/Makefile.org
-@@ -109,7 +109,7 @@ LIBKRB5=
- ZLIB_INCLUDE=
- LIBZLIB=
+@@ -135,7 +135,7 @@ FIPSCANLIB=
+
+ BASEADDR=
-DIRS= crypto ssl engines apps test tools
+DIRS= crypto ssl apps
diff --git a/package/openssl/patches/150-no_engines.patch b/package/openssl/patches/150-no_engines.patch
index f245fae27b..5d1e4f4fba 100644
--- a/package/openssl/patches/150-no_engines.patch
+++ b/package/openssl/patches/150-no_engines.patch
@@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
-@@ -1888,6 +1888,11 @@ EOF
+@@ -2000,6 +2000,11 @@ EOF
close(OUT);
}
diff --git a/package/openssl/patches/160-disable_doc_tests.patch b/package/openssl/patches/160-disable_doc_tests.patch
index 90f553a536..d0bf19a3ef 100644
--- a/package/openssl/patches/160-disable_doc_tests.patch
+++ b/package/openssl/patches/160-disable_doc_tests.patch
@@ -1,15 +1,15 @@
--- a/Makefile
+++ b/Makefile
-@@ -111,7 +111,7 @@ LIBKRB5=
- ZLIB_INCLUDE=
- LIBZLIB=
+@@ -137,7 +137,7 @@ FIPSCANLIB=
+
+ BASEADDR=0xFB00000
-DIRS= crypto ssl engines apps test tools
+DIRS= crypto ssl engines apps tools
ENGDIRS= ccgost
SHLIBDIRS= crypto ssl
-@@ -129,7 +129,7 @@ SDIRS= \
+@@ -155,7 +155,7 @@ SDIRS= \
# tests to perform. "alltests" is a special word indicating that all tests
# should be performed.
@@ -18,7 +18,7 @@
MAKEFILE= Makefile
-@@ -143,7 +143,7 @@ SHELL=/bin/sh
+@@ -169,7 +169,7 @@ SHELL=/bin/sh
TOP= .
ONEDIRS=out tmp
@@ -27,7 +27,7 @@
WDIRS= windows
LIBS= libcrypto.a libssl.a
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -239,7 +239,7 @@ reflect:
+@@ -270,7 +270,7 @@ reflect:
@[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
sub_all: build_all
@@ -36,7 +36,7 @@
build_libs: build_crypto build_ssl build_engines
-@@ -497,7 +497,7 @@ dist:
+@@ -539,7 +539,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -47,7 +47,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
--- a/Makefile.org
+++ b/Makefile.org
-@@ -495,7 +495,7 @@ dist:
+@@ -537,7 +537,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
diff --git a/package/openssl/patches/190-remove_timestamp_check.patch b/package/openssl/patches/190-remove_timestamp_check.patch
index d6ec497fd1..2677b2d6f1 100644
--- a/package/openssl/patches/190-remove_timestamp_check.patch
+++ b/package/openssl/patches/190-remove_timestamp_check.patch
@@ -1,6 +1,6 @@
--- a/Makefile.org
+++ b/Makefile.org
-@@ -158,7 +158,7 @@ WTARFILE= $(NAME)-win.tar
+@@ -184,7 +184,7 @@ WTARFILE= $(NAME)-win.tar
EXHEADER= e_os2.h
HEADER= e_os.h
@@ -9,7 +9,7 @@
# as we stick to -e, CLEARENV ensures that local variables in lower
# Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
-@@ -354,11 +354,6 @@ openssl.pc: Makefile
+@@ -396,11 +396,6 @@ openssl.pc: Makefile
echo 'Libs.private: $(EX_LIBS)'; \
echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
@@ -19,5 +19,5 @@
- @false
-
libclean:
- rm -f *.map *.so *.so.* *.dll engines/*.so engines/*.dll *.a engines/*.a */lib */*/lib
+ rm -f *.map *.so *.so.* *.dylib *.dll engines/*.so engines/*.dll engines/*.dylib *.a engines/*.a */lib */*/lib
diff --git a/package/openssl/patches/200-etrax_support.patch b/package/openssl/patches/200-etrax_support.patch
index 990988a743..9bd155e37d 100644
--- a/package/openssl/patches/200-etrax_support.patch
+++ b/package/openssl/patches/200-etrax_support.patch
@@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
-@@ -414,6 +414,10 @@ my %table=(
+@@ -440,6 +440,10 @@ my %table=(
"beos-x86-r5", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -mcpu=pentium -Wall::-D_REENTRANT:BEOS:-lbe -lnet:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:beos:beos-shared:-fPIC -DPIC:-shared:.so",
"beos-x86-bone", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -mcpu=pentium -Wall::-D_REENTRANT:BEOS:-lbe -lbind -lsocket:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:beos:beos-shared:-fPIC:-shared:.so",