aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-05-17 00:25:41 +0000
committerNicolas Thill <nico@openwrt.org>2009-05-17 00:25:41 +0000
commite3667594fb5a8ef407e756a335961caf4196d278 (patch)
tree010c3e0ce91d3eac4bf7c97c789392faf21a6263 /package/openssl
parent77051ce25b75105ec3c7916a1852573abc63fdbf (diff)
downloadupstream-e3667594fb5a8ef407e756a335961caf4196d278.tar.gz
upstream-e3667594fb5a8ef407e756a335961caf4196d278.tar.bz2
upstream-e3667594fb5a8ef407e756a335961caf4196d278.zip
[package] openssl: fix annoying build errors when changing upstream versions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15880 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 11a9ef2e28..55c9a1c623 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -93,8 +93,9 @@ endef
TARGET_CFLAGS += $(FPIC)
define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
+ # XXX: OpenSSL "make depend" will look for installed headers before its own,
+ # so remove installed stuff first
+ -$(SUBMAKE) -j1 clean-staging
$(MAKE) -C $(PKG_BUILD_DIR) \
MAKEDEPPROG="$(TARGET_CROSS)gcc" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \