aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-18 14:48:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-18 14:48:16 +0000
commitbaafb55f70c8f354c76ae7f6e7cf88cd1a489d88 (patch)
tree0c3849ccf4a86b2b451af73e4399f5937e4b9f0e /package/openssl
parent14af6398329f3cc686f68b51b9547d9f7d89a4b0 (diff)
downloadupstream-baafb55f70c8f354c76ae7f6e7cf88cd1a489d88.tar.gz
upstream-baafb55f70c8f354c76ae7f6e7cf88cd1a489d88.tar.bz2
upstream-baafb55f70c8f354c76ae7f6e7cf88cd1a489d88.zip
[package] openssl: fix syntax error in OpenWrt Makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29774 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 48e8a427f6..67f643c92f 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -142,7 +142,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc)
+ [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc || true
endef
define Package/libopenssl/install