aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-03 13:19:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-03 13:19:41 +0000
commit79e18c1ce0303a16bc83631b30a8365c332fb514 (patch)
tree0bba97e764b4d9be71601158d6cce9f65da80070 /package/openssl
parentfa32884c03e78437e7d04b3bb299afec5e9620d8 (diff)
downloadupstream-79e18c1ce0303a16bc83631b30a8365c332fb514.tar.gz
upstream-79e18c1ce0303a16bc83631b30a8365c332fb514.tar.bz2
upstream-79e18c1ce0303a16bc83631b30a8365c332fb514.zip
change the an openssl sed command to be safe for -Wl,-rpath-link in ldflags
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12511 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index f19551df3d..dce7550538 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -122,7 +122,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
mkdir -p $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef
define Package/libopenssl/install