aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commit5a325930579db5f9175bea19459c845746801ae4 (patch)
tree8b63e203323c3c4ab05aa9bf0a9ec17f5dc87c91 /package/openssl
parent7bc567a0409f4d9aa9a4e12e9c56bc892b737da3 (diff)
downloadupstream-5a325930579db5f9175bea19459c845746801ae4.tar.gz
upstream-5a325930579db5f9175bea19459c845746801ae4.tar.bz2
upstream-5a325930579db5f9175bea19459c845746801ae4.zip
replace lots of manual install commands with INSTALL_* variables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 7bb31c8cb3..827c4415c0 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -115,18 +115,18 @@ define Build/UninstallDev
endef
define Package/libopenssl/install
- install -d -m0755 $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
chmod 0644 $(1)/usr/lib/*
endef
define Package/openssl-util/install
- install -d -m0755 $(1)/etc/ssl
+ $(INSTALL_DIR) $(1)/etc/ssl
$(CP) $(PKG_INSTALL_DIR)/etc/ssl/openssl.cnf $(1)/etc/ssl/
- install -d -m0755 $(1)/etc/ssl/certs
- install -d -m0755 $(1)/etc/ssl/private
+ $(INSTALL_DIR) $(1)/etc/ssl/certs
+ $(INSTALL_DIR) $(1)/etc/ssl/private
chmod 0700 $(1)/etc/ssl/private
- install -d -m0755 $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
endef