aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-04-14 22:52:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-04-14 22:52:49 +0000
commit2ef7a2edc52d8431ca6a333f5878f96da532559c (patch)
tree5d97fcc1a4a121f9b96ffb50e882406008f27d53 /package/openssl
parentda1d443c2c6c0b55f18ebb6b269b88bc319afaa3 (diff)
downloadupstream-2ef7a2edc52d8431ca6a333f5878f96da532559c.tar.gz
upstream-2ef7a2edc52d8431ca6a333f5878f96da532559c.tar.bz2
upstream-2ef7a2edc52d8431ca6a333f5878f96da532559c.zip
openssl: remove the makefile timestamp check, it breaks on some host systems
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20858 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/patches/190-remove_timestamp_check.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/openssl/patches/190-remove_timestamp_check.patch b/package/openssl/patches/190-remove_timestamp_check.patch
new file mode 100644
index 0000000000..6157b906ab
--- /dev/null
+++ b/package/openssl/patches/190-remove_timestamp_check.patch
@@ -0,0 +1,23 @@
+--- a/Makefile
++++ b/Makefile
+@@ -181,7 +181,7 @@ WTARFILE= $(NAME)-win.tar
+ EXHEADER= e_os2.h
+ HEADER= e_os.h
+
+-all: Makefile build_all openssl.pc libssl.pc libcrypto.pc
++all: build_all openssl.pc libssl.pc libcrypto.pc
+
+ # as we stick to -e, CLEARENV ensures that local variables in lower
+ # Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
+@@ -476,11 +476,6 @@ openssl.pc: Makefile
+ echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
+
+-Makefile: Makefile.org Configure config
+- @echo "Makefile is older than Makefile.org, Configure or config."
+- @echo "Reconfigure the source tree (via './config' or 'perl Configure'), please."
+- @false
+-
+ libclean:
+ rm -f *.map *.so *.so.* *.dll engines/*.so engines/*.dll *.a engines/*.a */lib */*/lib
+