aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2012-07-11 23:38:16 +0000
committerLuka Perkov <luka@openwrt.org>2012-07-11 23:38:16 +0000
commit2bcc527dd7f0babdceb5c1dfc7a623b73a2fb80d (patch)
treedb6ff8454dc455a7007e85e08a63c07a1fe46d04 /package/openssl
parent7bb8a26e0cbb451c7d5bfc9a0aa9f70fcda03b3c (diff)
downloadupstream-2bcc527dd7f0babdceb5c1dfc7a623b73a2fb80d.tar.gz
upstream-2bcc527dd7f0babdceb5c1dfc7a623b73a2fb80d.tar.bz2
upstream-2bcc527dd7f0babdceb5c1dfc7a623b73a2fb80d.zip
openssl: enable the use of cryptodev digests
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32673 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Config.in7
-rw-r--r--package/openssl/Makefile9
2 files changed, 12 insertions, 4 deletions
diff --git a/package/openssl/Config.in b/package/openssl/Config.in
index 1d310bdb5d..11591de047 100644
--- a/package/openssl/Config.in
+++ b/package/openssl/Config.in
@@ -1,8 +1,13 @@
menu "Configuration"
depends on PACKAGE_libopenssl
-config OPENSSL_ENGINE
+config OPENSSL_ENGINE_CRYPTO
bool
prompt "Crypto acceleration support"
+config OPENSSL_ENGINE_DIGEST
+ bool
+ depends OPENSSL_ENGINE_CRYPTO
+ prompt "Digests acceleration support"
+
endmenu
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 7043aeeb18..d95783aac9 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
PKG_MD5SUM:=ae412727c8c15b67880aef7bd2999b2e
PKG_BUILD_DEPENDS:=ocf-crypto-headers
-PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
+PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE_CRYPTO CONFIG_OPENSSL_ENGINE_DIGEST
include $(INCLUDE_DIR)/package.mk
@@ -73,11 +73,14 @@ endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
- no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+ no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic no-sse2
-ifdef CONFIG_OPENSSL_ENGINE
+ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
OPENSSL_OPTIONS += -DHAVE_CRYPTODEV
+ ifdef CONFIG_OPENSSL_ENGINE_DIGEST
+ OPENSSL_OPTIONS += -DUSE_CRYPTODEV_DIGESTS
+ endif
else
OPENSSL_OPTIONS += no-engines
endif