aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-01-28 19:28:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-01-28 19:28:06 +0000
commit1a55960148d1af4444eb99efa0a77150f0a65628 (patch)
tree457a368799d36035983e49ea78a4ade0de24ba97 /package/openssl
parentaaddec14d15e6942ec7cc8d713537ba8c13551d6 (diff)
downloadupstream-1a55960148d1af4444eb99efa0a77150f0a65628.tar.gz
upstream-1a55960148d1af4444eb99efa0a77150f0a65628.tar.bz2
upstream-1a55960148d1af4444eb99efa0a77150f0a65628.zip
openssl: make engines support dynamically configurable (based on a patch by puchu)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19371 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Config.in9
-rw-r--r--package/openssl/Makefile20
2 files changed, 22 insertions, 7 deletions
diff --git a/package/openssl/Config.in b/package/openssl/Config.in
new file mode 100644
index 0000000000..96cba4916d
--- /dev/null
+++ b/package/openssl/Config.in
@@ -0,0 +1,9 @@
+# OpenSSL configuration
+
+if PACKAGE_libopenssl
+
+config OPENSSL_ENGINE
+ bool
+ prompt "Crypto acceleration support"
+
+endif
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index ac565218da..2d2a940499 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=0.9.8l
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -18,7 +18,8 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
PKG_MD5SUM:=05a0ece1372392a2cf310ebb96333025
-PKG_BUILD_DEPENDS:=ocf-crypto-headers
+PKG_BUILD_DEPENDS := ocf-crypto-headers
+PKG_CONFIG_DEPENDS := CONFIG_OPENSSL_ENGINE
include $(INCLUDE_DIR)/package.mk
@@ -27,6 +28,10 @@ define Package/openssl/Default
URL:=http://www.openssl.org/
endef
+define Package/libopenssl/config
+source "$(SOURCE)/Config.in"
+endef
+
define Package/openssl/Default/description
The OpenSSL Project is a collaborative effort to develop a robust,
commercial-grade, full-featured, and Open Source toolkit implementing the
@@ -69,13 +74,14 @@ endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
-ifeq ($(BOARD),ixp4xx)
-OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
- no-sse2 --with-cryptodev
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic no-sse2
+
+ifdef CONFIG_OPENSSL_ENGINE
+ OPENSSL_OPTIONS += --with-cryptodev
else
-OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
- no-engines no-sse2
+ OPENSSL_OPTIONS += no-engines
endif
+
ifdef CONFIG_arm
OPENSSL_MAKEFLAGS := AES_ASM_OBJ="aes-armv4.o aes_cbc.o"
else