aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-08-29 10:08:30 +0000
committerJohn Crispin <blogic@openwrt.org>2012-08-29 10:08:30 +0000
commit14fae1493676ed8a8fce26ce5aa7be842612e2bd (patch)
treec051565fe8652e2ae35b1dce34b8625e3ba59c6d /package/openssl
parented8e12587b540e218d8999c60fa512b9cb489931 (diff)
downloadupstream-14fae1493676ed8a8fce26ce5aa7be842612e2bd.tar.gz
upstream-14fae1493676ed8a8fce26ce5aa7be842612e2bd.tar.bz2
upstream-14fae1493676ed8a8fce26ce5aa7be842612e2bd.zip
[openssl] revert threadsafe patch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33292 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 123f393d5a..d95783aac9 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -58,7 +58,7 @@ define Package/openssl-util
$(call Package/openssl/Default)
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libopenssl +libpthread
+ DEPENDS:=+libopenssl
TITLE+= (utility)
endef
@@ -105,7 +105,7 @@ define Build/Configure
)
endef
-TARGET_CFLAGS += $(FPIC) -DOPENSSL_THREADS -pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE
+TARGET_CFLAGS += $(FPIC)
define Build/Compile
# XXX: OpenSSL "make depend" will look for installed headers before its own,