aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-18 23:54:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-18 23:54:08 +0000
commit04704e32450abd0f710e7d2e07855501fcb8421a (patch)
tree384ea17e526090e64dd7fc63843120791a77fded /package/openssl
parentf0cf4d40ce6c1d6efb04ba2353eaa6d5dc033dbc (diff)
downloadupstream-04704e32450abd0f710e7d2e07855501fcb8421a.tar.gz
upstream-04704e32450abd0f710e7d2e07855501fcb8421a.tar.bz2
upstream-04704e32450abd0f710e7d2e07855501fcb8421a.zip
openssl does not compile with uml and arch x86_64
Hi, I found that openssl did not compile on the uml target under x86_64. The attached patch should correct this and is working for me. Is this the right way to do it? thanks, Thomas git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32443 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index a696dd7cd4..7043aeeb18 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -82,11 +82,16 @@ else
OPENSSL_OPTIONS += no-engines
endif
-OPENSSL_OPTIONS += no-perlasm
+ifeq ($(CONFIG_x86_64),y)
+ OPENSSL_TARGET:=linux-x86_64
+else
+ OPENSSL_TARGET:=linux-openwrt
+ OPENSSL_OPTIONS+=no-perlasm no-sse2
+endif
define Build/Configure
(cd $(PKG_BUILD_DIR); \
- ./Configure linux-openwrt \
+ ./Configure $(OPENSSL_TARGET) \
--prefix=/usr \
--openssldir=/etc/ssl \
$(TARGET_CPPFLAGS) \