aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-24 15:23:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-24 15:23:57 +0000
commit6a72b90c872d7477e4b974e0a156ec1f4d0817de (patch)
tree03567abe024d4e769d5c2d539d85920429b66fb4 /package/openssl/Makefile
parente945b473b0b5b681114ab4c6c13685eeb41e06f1 (diff)
downloadupstream-6a72b90c872d7477e4b974e0a156ec1f4d0817de.tar.gz
upstream-6a72b90c872d7477e4b974e0a156ec1f4d0817de.tar.bz2
upstream-6a72b90c872d7477e4b974e0a156ec1f4d0817de.zip
openssl: use asm SHA1, SHA256, AES on MIPS.
On a lightly loaded 24Kc, as measured by 'openssl speed sha1', shows between 27% and 120% speedup depending on block size. SHA1 is notably used in Transmission for piece verification. Patch by Catalin Patulea SVN-Revision: 33531
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index d95783aac9..cfc3b3d92d 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -88,8 +88,13 @@ endif
ifeq ($(CONFIG_x86_64),y)
OPENSSL_TARGET:=linux-x86_64
else
- OPENSSL_TARGET:=linux-openwrt
- OPENSSL_OPTIONS+=no-perlasm no-sse2
+ OPENSSL_OPTIONS+=no-sse2
+ ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
+ OPENSSL_TARGET:=linux-mips-openwrt
+ else
+ OPENSSL_TARGET:=linux-generic-openwrt
+ OPENSSL_OPTIONS+=no-perlasm
+ endif
endif
define Build/Configure