aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-24 15:23:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-24 15:23:57 +0000
commit8eadb90934c02b121fcb25f81fc1eda9985b196b (patch)
tree474c4a4a8a0866e5b9fc0214614b3d3e0fe76459 /package/openssl/Makefile
parent7baa5e685931b85f29e8c6c9b21a2f322129f76e (diff)
downloadupstream-8eadb90934c02b121fcb25f81fc1eda9985b196b.tar.gz
upstream-8eadb90934c02b121fcb25f81fc1eda9985b196b.tar.bz2
upstream-8eadb90934c02b121fcb25f81fc1eda9985b196b.zip
openssl: use asm SHA1, SHA256, AES on MIPS.
On a lightly loaded 24Kc, as measured by 'openssl speed sha1', shows between 27% and 120% speedup depending on block size. SHA1 is notably used in Transmission for piece verification. Patch by Catalin Patulea git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33531 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index d95783aac9..cfc3b3d92d 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -88,8 +88,13 @@ endif
ifeq ($(CONFIG_x86_64),y)
OPENSSL_TARGET:=linux-x86_64
else
- OPENSSL_TARGET:=linux-openwrt
- OPENSSL_OPTIONS+=no-perlasm no-sse2
+ OPENSSL_OPTIONS+=no-sse2
+ ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
+ OPENSSL_TARGET:=linux-mips-openwrt
+ else
+ OPENSSL_TARGET:=linux-generic-openwrt
+ OPENSSL_OPTIONS+=no-perlasm
+ endif
endif
define Build/Configure