aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-10-06 23:50:47 +0000
committerJohn Crispin <blogic@openwrt.org>2007-10-06 23:50:47 +0000
commitcad1b620581f190548505014c91c17729fabac94 (patch)
tree0303d290259245f16a5feb334bf9f75a27b213e9 /package/openssl/Makefile
parent0b3ef78e450af9522061644d7a27e413b0a9cec2 (diff)
downloadupstream-cad1b620581f190548505014c91c17729fabac94.tar.gz
upstream-cad1b620581f190548505014c91c17729fabac94.tar.bz2
upstream-cad1b620581f190548505014c91c17729fabac94.zip
added our own pkg-config wrapper, making the sed foo on *.pc files obselete 1/2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 270fe5e755..555099bd07 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -115,8 +115,6 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
mkdir -p $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's,^includedir=.*,includedir=$(1)/usr/include,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
- $(SED) 's,^libdir=.*,libdir=$(1)/usr/lib,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
$(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef