aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:54:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:54:09 +0000
commita9c1f1c25fc479a96be521941a28bdf525a8ecfd (patch)
treee97e8d618f158fab156dabb3144485c98a04f561 /package/openssl/Makefile
parent20a5105819b1c5f39a2751f72cd00c4ad8396f61 (diff)
downloadupstream-a9c1f1c25fc479a96be521941a28bdf525a8ecfd.tar.gz
upstream-a9c1f1c25fc479a96be521941a28bdf525a8ecfd.tar.bz2
upstream-a9c1f1c25fc479a96be521941a28bdf525a8ecfd.zip
[package] openssl: don't fail with empty TARGET_LDFLAGS
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29770 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index cc253d686d..48e8a427f6 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -142,7 +142,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc)
endef
define Package/libopenssl/install