aboutsummaryrefslogtreecommitdiffstats
path: root/package/ocf-crypto-headers/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-18 20:50:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-18 20:50:18 +0000
commit646ee8826a74f63114dd2c1b2e0c85954b155aab (patch)
treeecd685eeda9e4efaabf44173e376c72b51dc86ec /package/ocf-crypto-headers/Makefile
parent27b7756e8304f0eac4c560ae5a7a24c3b92f0464 (diff)
downloadupstream-646ee8826a74f63114dd2c1b2e0c85954b155aab.tar.gz
upstream-646ee8826a74f63114dd2c1b2e0c85954b155aab.tar.bz2
upstream-646ee8826a74f63114dd2c1b2e0c85954b155aab.zip
[package] add package for ocf-crypto-headers
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13283 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ocf-crypto-headers/Makefile')
-rw-r--r--package/ocf-crypto-headers/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/ocf-crypto-headers/Makefile b/package/ocf-crypto-headers/Makefile
new file mode 100644
index 0000000000..cf9185a569
--- /dev/null
+++ b/package/ocf-crypto-headers/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ocf-crypto-headers
+PKG_VERSION:=20080917
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ocf-crypto-headers
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=OCF-Linux cryptodev header
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Build/InstallDev
+ mkdir -p $(1)/usr/include/crypto
+ $(CP) ./src/cryptodev.h $(1)/usr/include/crypto
+endef
+
+$(eval $(call BuildPackage,ocf-crypto-headers))