aboutsummaryrefslogtreecommitdiffstats
path: root/package/ocf-crypto-headers/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-18 20:50:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-18 20:50:18 +0000
commit0aa75baf816c47dd2d521c4ae863777ff2421e7b (patch)
tree6ada50272194abacb2e480c70d8f6f422d40c234 /package/ocf-crypto-headers/Makefile
parent006f326bc1a5cf2a93857f1cfeb69add83950fce (diff)
downloadupstream-0aa75baf816c47dd2d521c4ae863777ff2421e7b.tar.gz
upstream-0aa75baf816c47dd2d521c4ae863777ff2421e7b.tar.bz2
upstream-0aa75baf816c47dd2d521c4ae863777ff2421e7b.zip
add package for ocf-crypto-headers
SVN-Revision: 13283
Diffstat (limited to 'package/ocf-crypto-headers/Makefile')
-rw-r--r--package/ocf-crypto-headers/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/ocf-crypto-headers/Makefile b/package/ocf-crypto-headers/Makefile
new file mode 100644
index 0000000000..cf9185a569
--- /dev/null
+++ b/package/ocf-crypto-headers/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ocf-crypto-headers
+PKG_VERSION:=20080917
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ocf-crypto-headers
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=OCF-Linux cryptodev header
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Build/InstallDev
+ mkdir -p $(1)/usr/include/crypto
+ $(CP) ./src/cryptodev.h $(1)/usr/include/crypto
+endef
+
+$(eval $(call BuildPackage,ocf-crypto-headers))