aboutsummaryrefslogtreecommitdiffstats
path: root/package/nvram/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-27 12:57:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-27 12:57:57 +0000
commitace455e0c0a91444b232688a014cd358847f3c69 (patch)
tree3954dc33cb4c0855f125af58dc696a2b893a5ddf /package/nvram/Makefile
parent6eec3954effc6702e2f8459b27d77d5fe86e8c60 (diff)
downloadupstream-ace455e0c0a91444b232688a014cd358847f3c69.tar.gz
upstream-ace455e0c0a91444b232688a014cd358847f3c69.tar.bz2
upstream-ace455e0c0a91444b232688a014cd358847f3c69.zip
remove old nvram package
SVN-Revision: 15436
Diffstat (limited to 'package/nvram/Makefile')
-rw-r--r--package/nvram/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/package/nvram/Makefile b/package/nvram/Makefile
deleted file mode 100644
index 7fdf6b9ad9..0000000000
--- a/package/nvram/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=nvram
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/nvram
- SECTION:=utils
- CATEGORY:=Utilities
- DEPENDS:=@TARGET_brcm_2_4
- TITLE:=Broadcom config utility
-endef
-
-define Package/nvram/description
- This package contains an utility to control broadcom's 'nvram' config area.
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/InstallDev
- mkdir -p $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libnvram*.so $(1)/usr/lib/
-endef
-
-define Package/nvram/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libnvram*.so $(1)/usr/lib/
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,nvram))