aboutsummaryrefslogtreecommitdiffstats
path: root/package/ntpclient
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-07 01:12:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-07 01:12:51 +0000
commitbe5c7d2d2546417767bc5c3471b246fa4f94313e (patch)
tree302a83f06c200757c896bbabe23db4af10445042 /package/ntpclient
parent816e158a73c253f73d53ec19c73cf6c7ea2e3736 (diff)
downloadupstream-be5c7d2d2546417767bc5c3471b246fa4f94313e.tar.gz
upstream-be5c7d2d2546417767bc5c3471b246fa4f94313e.tar.bz2
upstream-be5c7d2d2546417767bc5c3471b246fa4f94313e.zip
add hotplug stuff to trunk/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2364 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ntpclient')
-rw-r--r--package/ntpclient/Makefile6
-rw-r--r--package/ntpclient/files/ntpclient.init11
2 files changed, 13 insertions, 4 deletions
diff --git a/package/ntpclient/Makefile b/package/ntpclient/Makefile
index 679e5fca59..31fe551947 100644
--- a/package/ntpclient/Makefile
+++ b/package/ntpclient/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ntpclient
PKG_VERSION:=2003_194
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=94e84d5c6023c5e1f3890b28d0a08c92
PKG_SOURCE_URL:=http://doolittle.faludi.com/ntpclient
@@ -26,8 +26,8 @@ $(PKG_BUILD_DIR)/.built:
touch $@
$(IPKG_NTPCLIENT):
- install -d -m0755 $(IDIR_NTPCLIENT)/etc/init.d
- install -m0755 ./files/ntpclient.init $(IDIR_NTPCLIENT)/etc/init.d/S60ntpclient
+ install -d -m0755 $(IDIR_NTPCLIENT)/etc/hotplug.d/iface
+ install -m0755 ./files/ntpclient.init $(IDIR_NTPCLIENT)/etc/hotplug.d/iface/10-ntpclient
install -d -m0755 $(IDIR_NTPCLIENT)/usr/sbin
install -m0755 $(PKG_BUILD_DIR)/ntpclient $(IDIR_NTPCLIENT)/usr/sbin/
$(RSTRIP) $(IDIR_NTPCLIENT)
diff --git a/package/ntpclient/files/ntpclient.init b/package/ntpclient/files/ntpclient.init
index 923022bfcc..2ad4beb773 100644
--- a/package/ntpclient/files/ntpclient.init
+++ b/package/ntpclient/files/ntpclient.init
@@ -1,2 +1,11 @@
#!/bin/sh
-/usr/sbin/ntpclient -c 1 -s -h pool.ntp.org &
+server=$(nvram get ntp_server)
+case "$ACTION" in
+ ifup)
+ ps x | grep '[n]tpclient' >&- || {
+ route -n 2>&- | grep '0.0.0.0' >&- && /usr/sbin/ntpclient -c 1 -s -h ${server:-pool.ntp.org} &
+ }
+ ;;
+ ifdown)
+ route -n 2>&- | grep '0.0.0.0' >&- || killall ntpclient 2>&- >&- ;;
+esac