aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-03-13 00:24:13 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-13 19:24:13 +0100
commite9c99e0f7f02e94d8e8ca3da4429f5221684c305 (patch)
treef741a37cba90d58172ec7a798edb396dd45dc292 /package/network
parente5440ec87163fa24d5df890bc60f0c3e65be8dd9 (diff)
downloadupstream-e9c99e0f7f02e94d8e8ca3da4429f5221684c305.tar.gz
upstream-e9c99e0f7f02e94d8e8ca3da4429f5221684c305.tar.bz2
upstream-e9c99e0f7f02e94d8e8ca3da4429f5221684c305.zip
iptables: backport missing init_extensions6() calls
This fixes ip6tables-nft no being able to use built-in extensions like icmp6. Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iptables/Makefile2
-rw-r--r--package/network/utils/iptables/patches/001-xtables-Call-init_extensions6-for-static-builds.patch68
2 files changed, 69 insertions, 1 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index f978173c9f..f8cf3ec6a5 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.8.7
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE_URL:=https://netfilter.org/projects/iptables/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/network/utils/iptables/patches/001-xtables-Call-init_extensions6-for-static-builds.patch b/package/network/utils/iptables/patches/001-xtables-Call-init_extensions6-for-static-builds.patch
new file mode 100644
index 0000000000..22ccfa533a
--- /dev/null
+++ b/package/network/utils/iptables/patches/001-xtables-Call-init_extensions6-for-static-builds.patch
@@ -0,0 +1,68 @@
+From e727ccad036e2cdba3339536c65c7ceef43c0740 Mon Sep 17 00:00:00 2001
+From: Erik Wilson <erik.e.wilson@gmail.com>
+Date: Tue, 13 Jul 2021 16:48:23 -0700
+Subject: [PATCH] xtables: Call init_extensions6() for static builds
+
+Initialize extensions from libext6 for cases where xtables is built statically.
+
+Closes: https://bugzilla.netfilter.org/show_bug.cgi?id=1550
+Signed-off-by: Erik Wilson <Erik.E.Wilson@gmail.com>
+Signed-off-by: Florian Westphal <fw@strlen.de>
+---
+ iptables/xtables-monitor.c | 1 +
+ iptables/xtables-restore.c | 1 +
+ iptables/xtables-save.c | 1 +
+ iptables/xtables-standalone.c | 1 +
+ iptables/xtables-translate.c | 1 +
+ 5 files changed, 5 insertions(+)
+
+--- a/iptables/xtables-monitor.c
++++ b/iptables/xtables-monitor.c
+@@ -628,6 +628,7 @@ int xtables_monitor_main(int argc, char
+ #if defined(ALL_INCLUSIVE) || defined(NO_SHARED_LIBS)
+ init_extensions();
+ init_extensions4();
++ init_extensions6();
+ #endif
+
+ if (nft_init(&h, AF_INET, xtables_ipv4)) {
+--- a/iptables/xtables-restore.c
++++ b/iptables/xtables-restore.c
+@@ -364,6 +364,7 @@ xtables_restore_main(int family, const c
+ #if defined(ALL_INCLUSIVE) || defined(NO_SHARED_LIBS)
+ init_extensions();
+ init_extensions4();
++ init_extensions6();
+ #endif
+ break;
+ case NFPROTO_ARP:
+--- a/iptables/xtables-save.c
++++ b/iptables/xtables-save.c
+@@ -202,6 +202,7 @@ xtables_save_main(int family, int argc,
+ #if defined(ALL_INCLUSIVE) || defined(NO_SHARED_LIBS)
+ init_extensions();
+ init_extensions4();
++ init_extensions6();
+ #endif
+ tables = xtables_ipv4;
+ d.commit = true;
+--- a/iptables/xtables-standalone.c
++++ b/iptables/xtables-standalone.c
+@@ -57,6 +57,7 @@ xtables_main(int family, const char *pro
+ #if defined(ALL_INCLUSIVE) || defined(NO_SHARED_LIBS)
+ init_extensions();
+ init_extensions4();
++ init_extensions6();
+ #endif
+
+ if (nft_init(&h, family, xtables_ipv4) < 0) {
+--- a/iptables/xtables-translate.c
++++ b/iptables/xtables-translate.c
+@@ -469,6 +469,7 @@ static int xtables_xlate_main_common(str
+ #if defined(ALL_INCLUSIVE) || defined(NO_SHARED_LIBS)
+ init_extensions();
+ init_extensions4();
++ init_extensions6();
+ #endif
+ tables = xtables_ipv4;
+ break;