aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-02-28 22:37:41 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-19 16:13:58 +0100
commit2f5088ef5f3abd581e82970d223206a87a3c1909 (patch)
tree9a84dbb06ab84712584ab6e611c3708305068673 /package/network
parent9586a270a06aa8305f066a07ca35ca4883035eed (diff)
downloadupstream-2f5088ef5f3abd581e82970d223206a87a3c1909.tar.gz
upstream-2f5088ef5f3abd581e82970d223206a87a3c1909.tar.bz2
upstream-2f5088ef5f3abd581e82970d223206a87a3c1909.zip
arptables: rename package to arptables-legacy
This prepare the introduction of arptables-nft. Add PROVIDES so dependencies are not broken, use ALTERNATIVES. Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/arptables/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/package/network/utils/arptables/Makefile b/package/network/utils/arptables/Makefile
index d1168ae68f..6f06c7037a 100644
--- a/package/network/utils/arptables/Makefile
+++ b/package/network/utils/arptables/Makefile
@@ -19,22 +19,25 @@ PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
-define Package/arptables
+define Package/arptables-legacy
SECTION:=net
CATEGORY:=Network
SUBMENU:=Firewall
TITLE:=ARP firewalling software
DEPENDS:=+kmod-arptables
URL:=https://git.netfilter.org/arptables/
+ PROVIDES:=arptables
+ ALTERNATIVES:=\
+ 200:/usr/sbin/arptables:/usr/sbin/arptables-legacy
endef
MAKE_FLAGS += \
COPT_FLAGS="$(TARGET_CFLAGS) -D__OPTIMIZE__=1" \
KERNEL_DIR="$(LINUX_DIR)"
-define Package/arptables/install
+define Package/arptables-legacy/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/arptables $(1)/usr/sbin/arptables-legacy
endef
-$(eval $(call BuildPackage,arptables))
+$(eval $(call BuildPackage,arptables-legacy))