aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorPerry Melange <isprotejesvalkata@gmail.com>2021-04-19 11:17:10 +0200
committerBaptiste Jonglez <git@bitsofnetworks.org>2021-06-21 09:28:23 +0200
commitb2a3df91fa7e9a7f8b9216a99496ecc935f3e56d (patch)
tree21ef611d3645e833adaa4d34e52464989514dfcc /package/network
parent3d0ed7d763b54f22520be74c0c7354947082ef0c (diff)
downloadupstream-b2a3df91fa7e9a7f8b9216a99496ecc935f3e56d.tar.gz
upstream-b2a3df91fa7e9a7f8b9216a99496ecc935f3e56d.tar.bz2
upstream-b2a3df91fa7e9a7f8b9216a99496ecc935f3e56d.zip
qos-scripts: add ifbN device before setting the link up
commit 50413e1ec83dedaea44558d5f37af5454156a46a replaced ifconfig with ip. In order to set a link state to up, the interface needs to be added first. Fixes: FS#3754 Signed-off-by: Perry Melange <isprotejesvalkata@gmail.com> [Add Fixes tag] Signed-off-by: Baptiste Jonglez <git@bitsofnetworks.org> (cherry picked from commit 23c3bab9209f984692f8206c0d97758ee223a26f)
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/qos-scripts/Makefile2
-rwxr-xr-xpackage/network/config/qos-scripts/files/usr/lib/qos/generate.sh3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/network/config/qos-scripts/Makefile b/package/network/config/qos-scripts/Makefile
index 7d282b2db5..d6e7df1467 100644
--- a/package/network/config/qos-scripts/Makefile
+++ b/package/network/config/qos-scripts/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=qos-scripts
PKG_VERSION:=1.3.1
-PKG_RELEASE:=2
+PKG_RELEASE:=$(AUTORELEASE)
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
diff --git a/package/network/config/qos-scripts/files/usr/lib/qos/generate.sh b/package/network/config/qos-scripts/files/usr/lib/qos/generate.sh
index 32f15581f8..62e7283633 100755
--- a/package/network/config/qos-scripts/files/usr/lib/qos/generate.sh
+++ b/package/network/config/qos-scripts/files/usr/lib/qos/generate.sh
@@ -326,7 +326,8 @@ start_interface() {
append cstr "$classnr:$prio:$avgrate:$pktsize:$pktdelay:$maxrate:$qdisc:$filter" "$N"
done
append ${prefix}q "$(tcrules)" "$N"
- export dev_${dir}="ip link set $dev up >&- 2>&-
+ export dev_${dir}="ip link add ${dev} type ifb >&- 2>&-
+ip link set $dev up >&- 2>&-
tc qdisc del dev $dev root >&- 2>&-
tc qdisc add dev $dev root handle 1: hfsc default ${class_default}0
tc class add dev $dev parent 1: classid 1:1 hfsc sc rate ${rate}kbit ul rate ${rate}kbit"