aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2017-05-31 16:24:11 +0200
committerJo-Philipp Wich <jo@mein.io>2017-12-13 15:50:45 +0100
commit41ee45428baab8c9cc365209caef8b03c86ae0e8 (patch)
treef303463f8b349ab5cbedcb6a6089bde2304e14b9 /package/network
parenta44c44077ea44f81a7ca88b59aac78f53cc09368 (diff)
downloadupstream-41ee45428baab8c9cc365209caef8b03c86ae0e8.tar.gz
upstream-41ee45428baab8c9cc365209caef8b03c86ae0e8.tar.bz2
upstream-41ee45428baab8c9cc365209caef8b03c86ae0e8.zip
ppp: propagate master firewall zone to dynamic slave interface
Assign the virtual DHCPv6 interface the firewall zone of the parent interface so fw3 knows the zone to which the virtual DHCPv6 interface belongs. This guarantees the firewall settings are applied correctly for the virtual DHCPv6 interface and allows to query the zone to which the virtual DHCPv6 interface belongs via the fw3 network option. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> (cherry picked from commit 21f25bc4a325b3075d6426047640e9cf6176894c)
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/ppp/Makefile2
-rwxr-xr-xpackage/network/services/ppp/files/lib/netifd/ppp6-up3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 8b0daf2295..6c615cab0b 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.7
-PKG_RELEASE:=11
+PKG_RELEASE:=12
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.samba.org/pub/ppp/
diff --git a/package/network/services/ppp/files/lib/netifd/ppp6-up b/package/network/services/ppp/files/lib/netifd/ppp6-up
index 8ad03223e5..3852bf63ff 100755
--- a/package/network/services/ppp/files/lib/netifd/ppp6-up
+++ b/package/network/services/ppp/files/lib/netifd/ppp6-up
@@ -17,10 +17,13 @@ proto_send_update "$PPP_IPPARAM"
}
if [ -n "$AUTOIPV6" ]; then
+ ZONE=$(fw3 -q network $PPP_IPPARAM 2>/dev/null)
+
json_init
json_add_string name "${PPP_IPPARAM}_6"
json_add_string ifname "@$PPP_IPPARAM"
json_add_string proto "dhcpv6"
+ [ -n "$ZONE" ] && json_add_string zone "$ZONE"
[ -n "$EXTENDPREFIX" ] && json_add_string extendprefix 1
[ -n "$IP6TABLE" ] && json_add_string ip6table $IP6TABLE
[ -n "$PEERDNS" ] && json_add_boolean peerdns $PEERDNS