aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-01-21 10:18:10 +0200
committerDaniel Golle <daniel@makrotopia.org>2020-01-21 10:25:27 +0200
commite4ce8f59f5f1a31961b29ae700829b8372053f77 (patch)
tree95c27c03af4b78efd98cd31f7f0edef76ff08462 /package/network
parent0d28e5d6440d2a37841a207f943e6e5a23172883 (diff)
downloadupstream-e4ce8f59f5f1a31961b29ae700829b8372053f77.tar.gz
upstream-e4ce8f59f5f1a31961b29ae700829b8372053f77.tar.bz2
upstream-e4ce8f59f5f1a31961b29ae700829b8372053f77.zip
netifd: add basic support for jail network namespaces
Prepare netifd for handling procd service jails having their own network namespace. Intefaces having the jail attribute will only be brought up inside the jail's network namespace by procd calling the newly introduced ubus method 'netns_updown'. Currently proto 'static' is supported and configuration changes are not yet being handled (ie. you'll have to restart the jailed service for changes to take effect). Example /etc/config/network snippet: config device 'veth0' option type 'veth' option name 'vhost0' option peer_name 'virt0' config interface 'virt' option type 'bridge' list ifname 'vhost0' option proto 'static' option ipaddr '10.0.0.1' option netmask '255.255.255.0' config interface 'virt0' option ifname 'virt0' option proto 'static' option ipaddr '10.0.0.2' option netmask '255.255.255.0' option gateway '10.0.0.1' option dns '10.0.0.1' option jail 'transmission' Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/netifd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 06c1aeac49..8a1bab8c44 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2020-01-07
-PKG_SOURCE_VERSION:=64f4eb79fe2977320660f8940bc908fa4def807b
-PKG_MIRROR_HASH:=d6c819856030118640e61bbc3abe20fdb6bca2b64b7adc437bcc2f71c8c01b64
+PKG_SOURCE_DATE:=2020-01-18
+PKG_SOURCE_VERSION:=1321c1bd8fe921986c4eb39c3783ddd827b79543
+PKG_MIRROR_HASH:=7e93ba79727e84cc391121be8a190cfa373dee8e2511f75d6f2fcb179928f5fa
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-2.0