aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-06-18 12:51:14 +0000
committerSteven Barth <cyrus@openwrt.org>2013-06-18 12:51:14 +0000
commit5219d38da29f879a86459a96ae3f5b2e1e33a95f (patch)
tree6389f4225c77355c48236eb8bcad252fcb6090fe /package/network
parent28535aad381d47a5e1fd384969eae4517e00a12c (diff)
downloadupstream-5219d38da29f879a86459a96ae3f5b2e1e33a95f.tar.gz
upstream-5219d38da29f879a86459a96ae3f5b2e1e33a95f.tar.bz2
upstream-5219d38da29f879a86459a96ae3f5b2e1e33a95f.zip
odhcp6c: Add option to override interface identifier in RA-client
SVN-Revision: 36959
Diffstat (limited to 'package/network')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile4
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.sh6
2 files changed, 6 insertions, 4 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 125dea8409..9d39fdfa37 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-06-13
+PKG_VERSION:=2013-06-18
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=83114b179091cb080f09cf4142ee1c9949ea4e30
+PKG_SOURCE_VERSION:=eaf3a11cad8a5dd389d5f52cc76e424e0242074b
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.sh b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
index b2264ed907..c5e77c65b4 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.sh
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
@@ -18,8 +18,8 @@ proto_dhcpv6_setup() {
local config="$1"
local iface="$2"
- local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
- json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
+ local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
+ json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
# Configure
@@ -35,6 +35,8 @@ proto_dhcpv6_setup() {
[ "$norelease" = "1" ] && append opts "-k"
+ [ -n "$ifaceid" ] && append opts "-i$ifaceid"
+
for opt in $reqopts; do
append opts "-r$opt"
done