aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorKyle Copperfield <kmcopper@danwin1210.me>2019-11-08 19:42:56 -0800
committerJohn Crispin <john@phrozen.org>2020-01-15 20:13:44 +0100
commit30c64825c7ed36452974733e53c591ff2dfd5336 (patch)
tree17b9a6e67238388e59ab076f66b2ca68466f3ae8 /package/network
parente96bfaedf3a342750d92fbfa773017e40e34bec3 (diff)
downloadupstream-30c64825c7ed36452974733e53c591ff2dfd5336.tar.gz
upstream-30c64825c7ed36452974733e53c591ff2dfd5336.tar.bz2
upstream-30c64825c7ed36452974733e53c591ff2dfd5336.zip
hostapd: add dtim_period, local_pwr_constraint, spectrum_mgmt_required
The sender domain has a DMARC Reject/Quarantine policy which disallows sending mailing list messages using the original "From" header. To mitigate this problem, the original message has been wrapped automatically by the mailing list software. Allows dtim_period to be configurable, the default is from hostapd. Adds additional regulatory tunables for power constraint and spectrum managment. Signed-off-by: Kyle Copperfield <kmcopper@danwin1210.me>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh13
2 files changed, 12 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 8dfcd89cc4..cc06a7abb6 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index dcbabaf8f1..ba41fcdc3c 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -90,6 +90,8 @@ hostapd_common_add_device_config() {
config_add_string country
config_add_boolean country_ie doth
+ config_add_boolean spectrum_mgmt_required
+ config_add_int local_pwr_constraint
config_add_string require_mode
config_add_boolean legacy_rates
@@ -106,11 +108,13 @@ hostapd_prepare_device_config() {
local base="${config%%.conf}"
local base_cfg=
- json_get_vars country country_ie beacon_int:100 doth require_mode legacy_rates acs_chan_bias
+ json_get_vars country country_ie beacon_int:100 dtim_period:2 doth require_mode legacy_rates \
+ acs_chan_bias local_pwr_constraint spectrum_mgmt_required
hostapd_set_log_options base_cfg
set_default country_ie 1
+ set_default spectrum_mgmt_required 0
set_default doth 1
set_default legacy_rates 1
@@ -119,7 +123,11 @@ hostapd_prepare_device_config() {
[ -n "$country" ] && {
append base_cfg "country_code=$country" "$N"
- [ "$country_ie" -gt 0 ] && append base_cfg "ieee80211d=1" "$N"
+ [ "$country_ie" -gt 0 ] && {
+ append base_cfg "ieee80211d=1" "$N"
+ [ -n "$local_pwr_constraint" ] && append base_cfg "local_pwr_constraint=$local_pwr_constraint" "$N"
+ [ "$spectrum_mgmt_required" -gt 0 ] && append base_cfg "spectrum_mgmt_required=$spectrum_mgmt_required" "$N"
+ }
[ "$hwmode" = "a" -a "$doth" -gt 0 ] && append base_cfg "ieee80211h=1" "$N"
}
@@ -154,6 +162,7 @@ hostapd_prepare_device_config() {
[ -n "$rlist" ] && append base_cfg "supported_rates=$rlist" "$N"
[ -n "$brlist" ] && append base_cfg "basic_rates=$brlist" "$N"
append base_cfg "beacon_int=$beacon_int" "$N"
+ append base_cfg "dtim_period=$dtim_period" "$N"
json_get_values opts hostapd_options
for val in $opts; do