aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2020-01-20 19:35:01 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2020-02-24 23:27:50 +0100
commit2d113f89d230c2d337ce03217b3b9c1ca22975ea (patch)
tree66a067a0ec983dfc6d38a8221d00cafcaaf39e53 /package/network
parent82679ca0b98fe42334ec4c2b36f5f7185aa7c637 (diff)
downloadupstream-2d113f89d230c2d337ce03217b3b9c1ca22975ea.tar.gz
upstream-2d113f89d230c2d337ce03217b3b9c1ca22975ea.tar.bz2
upstream-2d113f89d230c2d337ce03217b3b9c1ca22975ea.zip
hostapd: start hostapd/wpa_supplicant for all wiphy devices
c888e17e06 ("hostapd: manage instances via procd instead of pidfile") added procd support for managing hostapd and wpa_supplicant daemons but at the same time limited wiphy names to 'phy*'. This brings back initial behaviour (introduced in 60fb4c92b6 ("hostapd: add ubus reload") and makes procd manage daemons for any wiphy device found in '/sys/class/ieee80211'. CC: Felix Fietkau <nbd@nbd.name> CC: Daniel Golle <daniel@makrotopia.org> Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.hotplug2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d4e3115bf7..1deab44058 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.hotplug b/package/network/services/hostapd/files/hostapd.hotplug
index c319d42c1a..2c936fde75 100644
--- a/package/network/services/hostapd/files/hostapd.hotplug
+++ b/package/network/services/hostapd/files/hostapd.hotplug
@@ -21,7 +21,7 @@ service_data() {
procd_open_service hostapd
-for phy in phy*; do
+for phy in *; do
[ -d "$phy" ] || continue
mkdir -p /var/run/wpa_supplicant-$phy /var/run/hostapd-$phy