aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorrektide de la faye <rektide@voodoowarez.com>2017-12-14 01:29:11 -0500
committerHans Dedecker <dedeckeh@gmail.com>2017-12-29 18:06:25 +0100
commit0f72690a2df92d8701b96c55c870be22704cc7c7 (patch)
treed207c97b82ea05c1a6799618e8693ddb9c6493e8 /package/network
parent6e922a075654a770b8a1cf5e654b266c52912516 (diff)
downloadupstream-0f72690a2df92d8701b96c55c870be22704cc7c7.tar.gz
upstream-0f72690a2df92d8701b96c55c870be22704cc7c7.tar.bz2
upstream-0f72690a2df92d8701b96c55c870be22704cc7c7.zip
iptables: fix nftables compile issue (FS#711)
Enabling IPTABLES_NFTABLES resulted in an error during build:# *** No rule to make target '../extensions/libext.a', needed by 'xtables-compat-multi'." Comments from Alexander Lochmann and Fedor Konstantinov in FS#711 provided fixes for this build error, allowing iptables to compile. https://bugs.lede-project.org/index.php?do=details&task_id=711. This commit updates the Makefile.am xtables_compat_multi_LDFLAGS and _LDADD, moving linking of extensions to LDFLAGS. Signed-off-by: rektide de la faye <rektide@voodoowarez.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iptables/patches/600-shared-libext.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/network/utils/iptables/patches/600-shared-libext.patch b/package/network/utils/iptables/patches/600-shared-libext.patch
index 6704af5010..a906d40609 100644
--- a/package/network/utils/iptables/patches/600-shared-libext.patch
+++ b/package/network/utils/iptables/patches/600-shared-libext.patch
@@ -82,3 +82,23 @@
endif
xtables_multi_SOURCES += xshared.c
xtables_multi_LDADD += ../libxtables/libxtables.la -lm
+@@ -32,7 +35,8 @@ if ENABLE_NFTABLES
+ BUILT_SOURCES += xtables-config-parser.h
+ xtables_compat_multi_SOURCES = xtables-compat-multi.c iptables-xml.c
+ xtables_compat_multi_CFLAGS = ${AM_CFLAGS}
+-xtables_compat_multi_LDADD = ../extensions/libext.a ../extensions/libext_ebt.a
++xtables_compat_multi_LDADD =
++xtables_compat_multi_LDFLAGS = -L../extensions/ -liptext -liptext_ebt
+ if ENABLE_STATIC
+ xtables_compat_multi_CFLAGS += -DALL_INCLUSIVE
+ endif
+@@ -45,7 +49,8 @@ xtables_compat_multi_SOURCES += xtables-
+ getethertype.c nft-bridge.c \
+ xtables-eb-standalone.c xtables-eb.c \
+ xtables-translate.c
+-xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS} ../extensions/libext4.a ../extensions/libext6.a ../extensions/libext_ebt.a ../extensions/libext_arpt.a
++xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS}
++xtables_compat_multi_LDFLAGS += -liptext4 -liptext6 -liptext_arpt
+ # yacc and lex generate dirty code
+ xtables_compat_multi-xtables-config-parser.o xtables_compat_multi-xtables-config-syntax.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
+ xtables_compat_multi_SOURCES += xshared.c