aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-12-16 14:25:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-16 14:25:41 +0100
commit835947ce645e596f04f01cbda66292822fa915dd (patch)
tree21c0b161a1464402acec6689bc1bf93cf013c885 /package/network
parent02324da2063305d28ccda73ceb7eec68cf84b36c (diff)
downloadupstream-835947ce645e596f04f01cbda66292822fa915dd.tar.gz
upstream-835947ce645e596f04f01cbda66292822fa915dd.tar.bz2
upstream-835947ce645e596f04f01cbda66292822fa915dd.zip
hostapd: Make eapol-test depend on libubus
The eapol-test application also uses the code with the newly activated ubus support, add the missing dependency. Fixes: f5753aae233 ("hostapd: add support for WPS pushbutton station") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index a1480bf963..9623f54de1 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -393,7 +393,7 @@ define Package/eapol-test
SECTION:=net
CATEGORY:=Network
VARIANT:=supplicant-full-internal
- DEPENDS:=$(DRV_DEPENDS)
+ DEPENDS:=$(DRV_DEPENDS) +libubus
endef
define Package/eapol-test-openssl
@@ -402,7 +402,7 @@ define Package/eapol-test-openssl
CATEGORY:=Network
VARIANT:=supplicant-full-openssl
CONFLICTS:=$(filter-out eapol-test-openssl ,$(EAPOL_TEST_PROVIDERS))
- DEPENDS:=$(DRV_DEPENDS) +libopenssl
+ DEPENDS:=$(DRV_DEPENDS) +libubus +libopenssl
PROVIDES:=eapol-test
endef
@@ -412,7 +412,7 @@ define Package/eapol-test-wolfssl
CATEGORY:=Network
VARIANT:=supplicant-full-wolfssl
CONFLICTS:=$(filter-out eapol-test-openssl ,$(filter-out eapol-test-wolfssl ,$(EAPOL_TEST_PROVIDERS)))
- DEPENDS:=$(DRV_DEPENDS) +libwolfssl
+ DEPENDS:=$(DRV_DEPENDS) +libubus +libwolfssl
PROVIDES:=eapol-test
endef