aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-02-12 18:34:53 -0800
committerJo-Philipp Wich <jo@mein.io>2017-12-13 14:37:29 +0100
commit2dd9b62f82afba5dd1e7534cecfadad871d85885 (patch)
tree66cc218cc6406eba43bcd25248976906f434ab64 /package/network
parent2d31ec4c1bac03c0c2e76da504bef8967fa22e0d (diff)
downloadupstream-2dd9b62f82afba5dd1e7534cecfadad871d85885.tar.gz
upstream-2dd9b62f82afba5dd1e7534cecfadad871d85885.tar.bz2
upstream-2dd9b62f82afba5dd1e7534cecfadad871d85885.zip
rssileds: Fix build with external toolchains
Pass down TARGET_CPPFLAGS for path to header files, and append the libraries we depend on in TARGET_LDFLAGS. Put TARGET_LDFLAGS at the end of the command line as is required by modern GCC/binutils. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com> (cherry picked from commit 30159b3886849f94cd065ecece7ac988bfb89548)
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/rssileds/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/network/utils/rssileds/Makefile b/package/network/utils/rssileds/Makefile
index e475bcd5bb..d3fb66adc9 100644
--- a/package/network/utils/rssileds/Makefile
+++ b/package/network/utils/rssileds/Makefile
@@ -29,9 +29,11 @@ endef
define Build/Configure
endef
+TARGET_LDFLAGS += -liwinfo -luci -lubox -lnl-tiny
+
define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Wall -liwinfo \
- -o $(PKG_BUILD_DIR)/rssileds $(PKG_BUILD_DIR)/rssileds.c
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -Wall \
+ -o $(PKG_BUILD_DIR)/rssileds $(PKG_BUILD_DIR)/rssileds.c $(TARGET_LDFLAGS)
endef
define Package/rssileds/install