aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2012-10-19 15:34:28 +0000
committerHamish Guthrie <hcg@openwrt.org>2012-10-19 15:34:28 +0000
commita81ef914e0b41afc1dfd4292b8352e33f22dde22 (patch)
tree456cb3e98620d4ff6318a6e23ad37b6144ccda4c /package/network
parent810db7487c02e232e792c5a6dffdb4aac044615b (diff)
downloadupstream-a81ef914e0b41afc1dfd4292b8352e33f22dde22.tar.gz
upstream-a81ef914e0b41afc1dfd4292b8352e33f22dde22.tar.bz2
upstream-a81ef914e0b41afc1dfd4292b8352e33f22dde22.zip
licensing: Add licensing metadata to many packages
Two new variables are introduces to many packages, namely PKG_LICENSE and PKG_LICENSE_FILES - there may be more than one license applied to packages, and these are listed in the PKG_LICENSE variable and separated by spaces. All relevant license files are also added to the PKG_LICENSE_FILES variable, also space separated. The licensing metadata is put into the bin/<platform>/packages/Packages file for later parsing. A script for that is on it's way! git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33861 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/netifd/Makefile3
-rw-r--r--package/network/services/dnsmasq/Makefile3
-rw-r--r--package/network/services/dropbear/Makefile3
-rw-r--r--package/network/services/samba36/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 2f8453c420..047993a96b 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -13,6 +13,9 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
# PKG_MIRROR_MD5SUM:=
# CMAKE_INSTALL:=1
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
+
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 4ad0f37742..d92b00f998 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -15,6 +15,9 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
PKG_MD5SUM:=f47e5cb8f5bac6343f24b2dbe317ab40
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=COPYING
+
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL:=1
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 63cf86e147..cd5b368256 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -17,6 +17,9 @@ PKG_SOURCE_URL:= \
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
PKG_MD5SUM:=c627ffe09570fad7aa94d8eac2b9320c
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
+
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index d6b2b506e6..981ac59d90 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -16,6 +16,9 @@ PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_MD5SUM:=2f0c14547333c1b48fd4728b031e7040
+PKG_LICENSE:=GPLv3
+PKG_LICENSE_FILES:=COPYING
+
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_BUILD_PARALLEL:=1