aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2021-10-04 09:47:32 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-20 21:08:25 +0100
commit0e96e068672ee09e90c57c6b6cd0fc2c83d59868 (patch)
tree23e478fdfe3137412f91c7d6b088f5f627c656a9 /package/network/utils
parent9211af712f29556be2d1a757a0d17c55580e4eab (diff)
downloadupstream-0e96e068672ee09e90c57c6b6cd0fc2c83d59868.tar.gz
upstream-0e96e068672ee09e90c57c6b6cd0fc2c83d59868.tar.bz2
upstream-0e96e068672ee09e90c57c6b6cd0fc2c83d59868.zip
nftables: install libnftables to staging dir
Makes libnftables library and headers available for other packages. Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/nftables/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index 8ead30a127..89bb10e0da 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nftables
PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
@@ -61,6 +61,12 @@ endif
TARGET_CFLAGS += -flto
TARGET_LDFLAGS += -flto
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/nftables $(1)/usr/include/
+endef
+
define Package/nftables/install/Default
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/nft $(1)/usr/sbin/