aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-12-14 09:47:05 +0100
committerHans Dedecker <dedeckeh@gmail.com>2018-12-14 09:57:15 +0100
commit6ff27cf0f5f2eaf2044a454395b59260c2227597 (patch)
tree2d30ab2d13ebf8bdeaee08a555179b265cf1b84a /package/network/utils
parent81bb9189e4e598f04a0675e4c4aa0dc9c57db4ba (diff)
downloadupstream-6ff27cf0f5f2eaf2044a454395b59260c2227597.tar.gz
upstream-6ff27cf0f5f2eaf2044a454395b59260c2227597.tar.bz2
upstream-6ff27cf0f5f2eaf2044a454395b59260c2227597.zip
iproute2: backport patch fixing incorrect usage of LDFLAGS
Backport upstream patch fixing incorrect passing of -lxtables to LDFLAGS instead of LDLIBS in the tc/Makefile Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/iproute2/Makefile2
-rw-r--r--package/network/utils/iproute2/patches/002-tc-fix-xtables-incorrect-usage-of-LDFLAGS.patch35
2 files changed, 36 insertions, 1 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 5bd3bd89cc..6d3305b5ad 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=4.19.0
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
diff --git a/package/network/utils/iproute2/patches/002-tc-fix-xtables-incorrect-usage-of-LDFLAGS.patch b/package/network/utils/iproute2/patches/002-tc-fix-xtables-incorrect-usage-of-LDFLAGS.patch
new file mode 100644
index 0000000000..d5981360a9
--- /dev/null
+++ b/package/network/utils/iproute2/patches/002-tc-fix-xtables-incorrect-usage-of-LDFLAGS.patch
@@ -0,0 +1,35 @@
+From 6ddb36c3a9686df1cca2f4d06518395f1eb9d5cc Mon Sep 17 00:00:00 2001
+From: Syrone Wong <wong.syrone@gmail.com>
+Date: Wed, 12 Dec 2018 19:35:08 +0800
+Subject: [PATCH] tc: fix xtables incorrect usage of LDFLAGS
+
+The incorrect setting of LDFLAGS causes error below:
+
+> em_ipt.o: In function `em_ipt_print_epot':
+> em_ipt.c:(.text.em_ipt_print_epot+0x2e): undefined reference to
+> `xtables_init_all'
+
+em_ipt.c gets involved when TC_CONFIG_XT=y, which requires xtables,
+while tc/Makefile doesn't pass flags correctly. It adds '-lxtables'
+to LDFLAGS instead of LDLIBS.
+
+Fixes: dd296215 ("tc: add em_ipt ematch for calling xtables matches from tc matching context")
+
+Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
+Acked-by: Eyal Birger <eyal.birger@gmail.com>
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
+---
+ tc/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/tc/Makefile
++++ b/tc/Makefile
+@@ -170,7 +170,7 @@ em_ipset.o: CFLAGS += $$($(PKG_CONFIG) x
+ em_ipt.o: CFLAGS += $$($(PKG_CONFIG) xtables --cflags)
+
+ ifeq ($(TC_CONFIG_XT),y)
+- LDFLAGS += $$($(PKG_CONFIG) xtables --libs)
++ LDLIBS += $$($(PKG_CONFIG) xtables --libs)
+ endif
+
+ %.yacc.c: %.y