aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorRosy Song <rosysong@rosinson.com>2018-08-09 14:47:31 +0800
committerJo-Philipp Wich <jo@mein.io>2018-12-18 11:28:14 +0100
commitb3cc304e4552aa29721941406a885cd8e8987a5b (patch)
tree117fb1bd5ee7d55b099ab4c54c51a71f821f0aef /package/network/utils
parent468a4b5b6279423d96e537330dde1ff76d2198ed (diff)
downloadupstream-b3cc304e4552aa29721941406a885cd8e8987a5b.tar.gz
upstream-b3cc304e4552aa29721941406a885cd8e8987a5b.tar.bz2
upstream-b3cc304e4552aa29721941406a885cd8e8987a5b.zip
iptables: fix dependency for libip6tc on IPV6
Signed-off-by: Rosy Song <rosysong@rosinson.com> (backported from 2dc1f54b1205094e7c6036cae6275d2c326bad3e)
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 9c7179c51d..c1e4790d11 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -462,7 +462,7 @@ define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libip4tc +libip6tc +libxtables
+ DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
ABI_VERSION:=$(PKG_VERSION)
TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
endef
@@ -482,7 +482,7 @@ $(call Package/iptables/Default)
CATEGORY:=Libraries
TITLE:=IPv6 firewall - shared libiptc library
ABI_VERSION:=$(PKG_VERSION)
- DEPENDS:=+libxtables
+ DEPENDS:=@IPV6 +libxtables
endef
define Package/libxtables