aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xdp-tools/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-07-06 22:20:25 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-07-06 22:38:20 +0100
commitd29722e6ff764d78428c54a5618b7a0e191245f1 (patch)
treef6cf711017d07fcdca8d1653bca7581c843a68ba /package/network/utils/xdp-tools/Makefile
parent8288a4bbb368fc050f46c7e97a1c1b7b0e0c66c2 (diff)
downloadupstream-d29722e6ff764d78428c54a5618b7a0e191245f1.tar.gz
upstream-d29722e6ff764d78428c54a5618b7a0e191245f1.tar.bz2
upstream-d29722e6ff764d78428c54a5618b7a0e191245f1.zip
xdp-tools: fix build with NLS enabled
Make sure the 'configure' shell script finds the libintl when linking the test programs for discovering libpcap and libbpf. Reported-by: @trippleflux Fixes: 6ad1bea2a603 ("xdp-tools: add package") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/network/utils/xdp-tools/Makefile')
-rw-r--r--package/network/utils/xdp-tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/network/utils/xdp-tools/Makefile b/package/network/utils/xdp-tools/Makefile
index f0af555919..7d831d0fec 100644
--- a/package/network/utils/xdp-tools/Makefile
+++ b/package/network/utils/xdp-tools/Makefile
@@ -16,6 +16,7 @@ PKG_FLAGS:=nonshared
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/bpf.mk
+include $(INCLUDE_DIR)/nls.mk
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@@ -76,6 +77,8 @@ define Package/xdpdump/description
xdpdump - a simple tcpdump like tool for capturing packets at the XDP layer
endef
+TARGET_LDFLAGS += $(INTL_LDFLAGS)
+
CONFIGURE_VARS += \
FORCE_SYSTEM_LIBBPF=1 \
CC="$(TARGET_CC)" \