aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/wpan-tools
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-07-03 23:29:21 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-10 18:16:34 +0200
commit3707e5cbe33b6d00c3405fb6fead6cc1677b01ca (patch)
tree9e0db9e0ff39bc7a46beec3a5e648a2e686a804e /package/network/utils/wpan-tools
parent6902af4f3075154b5d1de207452a8a5668f95203 (diff)
downloadupstream-3707e5cbe33b6d00c3405fb6fead6cc1677b01ca.tar.gz
upstream-3707e5cbe33b6d00c3405fb6fead6cc1677b01ca.tar.bz2
upstream-3707e5cbe33b6d00c3405fb6fead6cc1677b01ca.zip
wpan-tools: cleanup Makefile
- Use SPDX - Add PKG_RELEASE - Change wpan.cakelab.org to linux-wpan.org/wpan-tools.html - Switch to github.com as PKG_SOURCE_URL Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/network/utils/wpan-tools')
-rw-r--r--package/network/utils/wpan-tools/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/package/network/utils/wpan-tools/Makefile b/package/network/utils/wpan-tools/Makefile
index 060aaf5046..309a819cd4 100644
--- a/package/network/utils/wpan-tools/Makefile
+++ b/package/network/utils/wpan-tools/Makefile
@@ -1,18 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
#
# Copyright (C) 2015 OpenWrt.org
#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
include $(TOPDIR)/rules.mk
PKG_NAME:=wpan-tools
PKG_VERSION:=0.7
+PKG_RELEASE=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://wpan.cakelab.org/releases/
-PKG_HASH:=c16de9d7861c2d9b6a4436a0fac730f9f545ee290b92bc770c538ec6a3f22309
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/linux-wpan/wpan-tools/releases/download/$(PKG_NAME)-$(PKG_VERSION)/$(PKG_NAME)-$(PKG_VERSION).tar.gz?
+PKG_HASH:=8b690ff0e71e08bece5ec541223fda7abd2d5552d97d3d25b4967609b58fef00
include $(INCLUDE_DIR)/package.mk
@@ -20,7 +19,7 @@ define Package/wpan-tools
SECTION:=net
CATEGORY:=Network
TITLE:=cfg802154 interface configuration utility
- URL:=http://wpan.cakelab.org/
+ URL:=https://linux-wpan.org/wpan-tools.html
DEPENDS:= +libnl
endef