aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/uqmi
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-09-15 19:16:52 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-09-17 18:32:28 +0200
commit7347ea7453aed1f5e6bf222761e3e5bd6b5d13e7 (patch)
tree5312a436c876f332cda264a3e5856b7c8f4e9553 /package/network/utils/uqmi
parentde76cefd865c2f39bb611f6403bb8e86a23aae18 (diff)
downloadupstream-7347ea7453aed1f5e6bf222761e3e5bd6b5d13e7.tar.gz
upstream-7347ea7453aed1f5e6bf222761e3e5bd6b5d13e7.tar.bz2
upstream-7347ea7453aed1f5e6bf222761e3e5bd6b5d13e7.zip
uqmi: pass-through ipXtable to child interfaces
Allow setting specific routing tables via the ip4table and ip6table options also when ${ifname}_4 and ${ifname}_6 child interfaces are being created. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit e51aa699f7ca3ce83a0add622c0fd17d0caafc46)
Diffstat (limited to 'package/network/utils/uqmi')
-rw-r--r--package/network/utils/uqmi/Makefile2
-rwxr-xr-xpackage/network/utils/uqmi/files/lib/netifd/proto/qmi.sh5
2 files changed, 5 insertions, 2 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index 21b3c7eba6..640cbe4e1b 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uqmi
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/uqmi.git
diff --git a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
index 05055b1484..c60cae653a 100755
--- a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
+++ b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
@@ -29,9 +29,10 @@ proto_qmi_setup() {
local interface="$1"
local dataformat connstat
local device apn auth username password pincode delay modes pdptype profile dhcpv6 autoconnect plmn $PROTO_DEFAULT_OPTIONS
+ local ip4table ip6table
local cid_4 pdh_4 cid_6 pdh_6
local ip_6 ip_prefix_length gateway_6 dns1_6 dns2_6
- json_get_vars device apn auth username password pincode delay modes pdptype profile dhcpv6 autoconnect plmn $PROTO_DEFAULT_OPTIONS
+ json_get_vars device apn auth username password pincode delay modes pdptype profile dhcpv6 autoconnect plmn ip4table ip6table $PROTO_DEFAULT_OPTIONS
[ "$metric" = "" ] && metric="0"
@@ -252,6 +253,7 @@ proto_qmi_setup() {
json_add_string name "${interface}_6"
json_add_string ifname "@$interface"
json_add_string proto "dhcpv6"
+ [ -n "$ip6table" ] && json_add_string ip6table "$ip6table"
proto_add_dynamic_defaults
# RFC 7278: Extend an IPv6 /64 Prefix to LAN
json_add_string extendprefix 1
@@ -265,6 +267,7 @@ proto_qmi_setup() {
json_add_string name "${interface}_4"
json_add_string ifname "@$interface"
json_add_string proto "dhcp"
+ [ -n "$ip4table" ] && json_add_string ip4table "$ip4table"
proto_add_dynamic_defaults
json_close_object
ubus call network add_dynamic "$(json_dump)"