aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/tcpdump
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-02 21:16:21 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-21 18:28:22 +0100
commitda3700988d9e34e380bae21ee23d5458a7e972b4 (patch)
tree20d82e514ac77f4f0de8deb7f1274a8f409646df /package/network/utils/tcpdump
parent5c545bdb365a78b8995ddfa441a6018f7ff3c011 (diff)
downloadupstream-da3700988d9e34e380bae21ee23d5458a7e972b4.tar.gz
upstream-da3700988d9e34e380bae21ee23d5458a7e972b4.tar.bz2
upstream-da3700988d9e34e380bae21ee23d5458a7e972b4.zip
treewide: add support for "gc-sections" in PKG_BUILD_FLAGS
This reduces open coding and allows to easily add a knob to enable it treewide, where chosen packages can still opt-out via "no-gc-sections". Note: libnl, mbedtls and opkg only used the CFLAGS part without the LDFLAGS counterpart. That doesn't help at all if the goal is to produce smaller binaries. I consider that an accident, and this fixes it. Note: there are also packages using only the LDFLAGS part. I didn't touch those, as gc might have been disabled via CFLAGS intentionally. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/network/utils/tcpdump')
-rw-r--r--package/network/utils/tcpdump/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/network/utils/tcpdump/Makefile b/package/network/utils/tcpdump/Makefile
index 827a66e860..e07e9feb6d 100644
--- a/package/network/utils/tcpdump/Makefile
+++ b/package/network/utils/tcpdump/Makefile
@@ -20,6 +20,7 @@ PKG_LICENSE:=BSD-3-Clause
PKG_CPE_ID:=cpe:/a:tcpdump:tcpdump
PKG_INSTALL:=1
+PKG_BUILD_FLAGS:=gc-sections
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -48,9 +49,6 @@ CONFIGURE_ARGS += \
--without-crypto \
$(call autoconf_bool,CONFIG_IPV6,ipv6)
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
-
ifeq ($(BUILD_VARIANT),mini)
TARGET_CFLAGS += -DTCPDUMP_MINI
CONFIGURE_ARGS += --disable-smb