aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/rssileds/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-02-12 18:34:53 -0800
committerFlorian Fainelli <f.fainelli@gmail.com>2017-03-01 17:19:52 -0800
commit30159b3886849f94cd065ecece7ac988bfb89548 (patch)
treefc215e1aa9426972b7f11e80b90152264e197896 /package/network/utils/rssileds/Makefile
parent4aa1560de3ce7e1ce813f450025ee0c55ab868eb (diff)
downloadupstream-30159b3886849f94cd065ecece7ac988bfb89548.tar.gz
upstream-30159b3886849f94cd065ecece7ac988bfb89548.tar.bz2
upstream-30159b3886849f94cd065ecece7ac988bfb89548.zip
rssileds: Fix build with external toolchains
Pass down TARGET_CPPFLAGS for path to header files, and append the libraries we depend on in TARGET_LDFLAGS. Put TARGET_LDFLAGS at the end of the command line as is required by modern GCC/binutils. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/network/utils/rssileds/Makefile')
-rw-r--r--package/network/utils/rssileds/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/network/utils/rssileds/Makefile b/package/network/utils/rssileds/Makefile
index e475bcd5bb..d3fb66adc9 100644
--- a/package/network/utils/rssileds/Makefile
+++ b/package/network/utils/rssileds/Makefile
@@ -29,9 +29,11 @@ endef
define Build/Configure
endef
+TARGET_LDFLAGS += -liwinfo -luci -lubox -lnl-tiny
+
define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Wall -liwinfo \
- -o $(PKG_BUILD_DIR)/rssileds $(PKG_BUILD_DIR)/rssileds.c
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -Wall \
+ -o $(PKG_BUILD_DIR)/rssileds $(PKG_BUILD_DIR)/rssileds.c $(TARGET_LDFLAGS)
endef
define Package/rssileds/install