aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/owipcalc/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-22 10:46:10 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-23 12:43:29 +0100
commit511d71e6895f3902612879ea5a09926a9f926569 (patch)
tree3ad8a2bf90f263524149924a0a539503ba06249b /package/network/utils/owipcalc/Makefile
parent465eaa0e0701253dc2ce9101073f94aba741c323 (diff)
downloadupstream-511d71e6895f3902612879ea5a09926a9f926569.tar.gz
upstream-511d71e6895f3902612879ea5a09926a9f926569.tar.bz2
upstream-511d71e6895f3902612879ea5a09926a9f926569.zip
owipcalc: remove package
This is a helpful utility, but it does not have any dependencies in this repository. Move it to packages feed. Cc: Jo-Philipp Wich <jo@mein.io> Cc: Nick Hainke <vincent@systemli.org> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/network/utils/owipcalc/Makefile')
-rw-r--r--package/network/utils/owipcalc/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/network/utils/owipcalc/Makefile b/package/network/utils/owipcalc/Makefile
deleted file mode 100644
index dc68a0346b..0000000000
--- a/package/network/utils/owipcalc/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-#
-# Copyright (C) 2012 Jo-Philipp Wich <jo@mein.io>
-#
-# This is free software, licensed under the Apache 2 license.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=owipcalc
-PKG_RELEASE:=5
-PKG_LICENSE:=Apache-2.0
-
-include $(INCLUDE_DIR)/package.mk
-
-
-define Package/owipcalc
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Simple IPv4/IPv6 address calculator
- MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-endef
-
-define Package/owipcalc/description
- The owipcalc utility supports a number of calculations and tests to work
- with ip-address ranges, this is useful for scripts that e.g. need to
- partition ipv6-prefixes into small subnets or to calculate address ranges
- for dhcp pools.
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) \
- -o $(PKG_BUILD_DIR)/owipcalc $(PKG_BUILD_DIR)/owipcalc.c
-endef
-
-
-define Package/owipcalc/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/owipcalc $(1)/usr/bin/owipcalc
-endef
-
-$(eval $(call BuildPackage,owipcalc))