aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/layerscape/restool/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-10-18 10:37:58 +0800
committerJohn Crispin <john@phrozen.org>2017-11-10 23:00:47 +0100
commit23c1504059e187a279296bc827878c8dc314cc05 (patch)
treef1c71d63bc0ee8802de9931d189c35148dbb6567 /package/network/utils/layerscape/restool/Makefile
parent1e0276a39af1094cff925148cc8340fc1893056d (diff)
downloadupstream-23c1504059e187a279296bc827878c8dc314cc05.tar.gz
upstream-23c1504059e187a279296bc827878c8dc314cc05.tar.bz2
upstream-23c1504059e187a279296bc827878c8dc314cc05.zip
layerscape: add restool package
restool is a user space application providing the ability to dynamically create and manage Layerscape DPAA2 containers and objects from Linux. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/network/utils/layerscape/restool/Makefile')
-rw-r--r--package/network/utils/layerscape/restool/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/network/utils/layerscape/restool/Makefile b/package/network/utils/layerscape/restool/Makefile
new file mode 100644
index 0000000000..9340861152
--- /dev/null
+++ b/package/network/utils/layerscape/restool/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright 2017 NXP
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=restool
+PKG_VERSION:=2017.09
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/qoriq-open-source/restool.git
+PKG_SOURCE_VERSION:=8f08b9d499e84f9057784c2036f0ddf75ae3fc70
+PKG_MIRROR_HASH:=ff672b420041deac190cc9ddf314c52ec325567c429bc0aca3c692b2c7dc818f
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/restool
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=@TARGET_layerscape
+ TITLE:=Layerscape DPAA2 dynamical management tool
+endef
+
+MAKE_FLAGS += \
+ DESTDIR="$(PKG_BUILD_DIR)"/output/ \
+ install
+
+define Package/restool/install
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(CP) $(PKG_BUILD_DIR)/output/usr/local/bin/* $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,restool))