aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iw/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-08-12 21:43:08 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-03 17:59:19 +0200
commit9a4fb78e7c4aeb795111693088f40d98216dd3e4 (patch)
tree45d2dd07e4f92bb72210fe13961fcca98149db19 /package/network/utils/iw/Makefile
parent4791afa734d4754cd92c65feffc60e62e4dc5c60 (diff)
downloadupstream-9a4fb78e7c4aeb795111693088f40d98216dd3e4.tar.gz
upstream-9a4fb78e7c4aeb795111693088f40d98216dd3e4.tar.bz2
upstream-9a4fb78e7c4aeb795111693088f40d98216dd3e4.zip
iw: Update to version 5.3
Wifi HE (ieee80211ax) parsing is currently only activated in the full version because it increases the compressed size by 2.5KBytes. This also activates link time optimization (LTO) again, the problem was fixed upstream This increases the uncompressed binary size of iw-tiny by about 1.7% old: 34446 iw_5.0.1-1_mipsel_24kc.ipk new: 35064 iw_5.3-1_mipsel_24kc.ipk Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network/utils/iw/Makefile')
-rw-r--r--package/network/utils/iw/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/network/utils/iw/Makefile b/package/network/utils/iw/Makefile
index 64438a1931..47bee53ca3 100644
--- a/package/network/utils/iw/Makefile
+++ b/package/network/utils/iw/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iw
-PKG_VERSION:=5.0.1
+PKG_VERSION:=5.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/network/iw
-PKG_HASH:=1e38ea794a223525b2ea7fe78fd14f2a56121e62e21ba5f9dbe8c494b35b5c0d
+PKG_HASH:=04afe857bc8dea67e461946de30ae1b012954b6965839c5c3fda7d0ed15505d5
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-2.0
@@ -46,7 +46,8 @@ TARGET_CPPFLAGS:= \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
$(TARGET_CPPFLAGS) \
-DCONFIG_LIBNL20 \
- -D_GNU_SOURCE
+ -D_GNU_SOURCE \
+ -flto
ifeq ($(BUILD_VARIANT),full)
TARGET_CPPFLAGS += -DIW_FULL
@@ -55,7 +56,7 @@ endif
MAKE_FLAGS += \
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -ffunction-sections -fdata-sections" \
- LDFLAGS="$(TARGET_LDFLAGS) -Wl,--gc-sections" \
+ LDFLAGS="$(TARGET_LDFLAGS) -Wl,--gc-sections -flto" \
NL1FOUND="" NL2FOUND=Y \
NLLIBNAME="libnl-tiny" \
LIBS="-lm -lnl-tiny" \