aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iputils/Makefile
diff options
context:
space:
mode:
authorCarsten Wolff <carsten@wolffcarsten.de>2018-04-08 21:39:10 +0200
committerJo-Philipp Wich <jo@mein.io>2019-01-22 09:05:59 +0100
commit2bf22b1fb725b71ca1ec2656be4b020efcc29289 (patch)
treeec67262152497341d041ef05ede4c39c91e5af00 /package/network/utils/iputils/Makefile
parentcf8483cb4ffc99bf3f512bb134860ccc8c099abe (diff)
downloadupstream-2bf22b1fb725b71ca1ec2656be4b020efcc29289.tar.gz
upstream-2bf22b1fb725b71ca1ec2656be4b020efcc29289.tar.bz2
upstream-2bf22b1fb725b71ca1ec2656be4b020efcc29289.zip
iputils: install ping, ping6, traceroute6 with setuid root
these utilities need to run with uid 0 to be useful. Thus, install them setuid root like other distros do, too. Signed-off-by: Carsten Wolff <carsten@wolffcarsten.de> [use INSTALL_SUID macro] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network/utils/iputils/Makefile')
-rw-r--r--package/network/utils/iputils/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/utils/iputils/Makefile b/package/network/utils/iputils/Makefile
index 344af07afd..03ad7d2031 100644
--- a/package/network/utils/iputils/Makefile
+++ b/package/network/utils/iputils/Makefile
@@ -144,12 +144,12 @@ endef
define Package/iputils-ping/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/ping $(1)/usr/bin/
+ $(INSTALL_SUID) $(PKG_BUILD_DIR)/ping $(1)/usr/bin/
endef
define Package/iputils-ping6/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/ping6 $(1)/usr/bin/
+ $(INSTALL_SUID) $(PKG_BUILD_DIR)/ping6 $(1)/usr/bin/
endef
define Package/iputils-tftpd/install
@@ -169,7 +169,7 @@ endef
define Package/iputils-traceroute6/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/traceroute6 $(1)/usr/bin/
+ $(INSTALL_SUID) $(PKG_BUILD_DIR)/traceroute6 $(1)/usr/bin/
endef
$(eval $(call BuildPackage,iputils-arping))