aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables/Makefile
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-02-21 16:20:34 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-28 21:52:01 +0100
commitd35a573004ff21e5a7bbdb896967454c63b7a363 (patch)
tree0f1ae2d44ec5bcc7022bed51d950644cf2348e8c /package/network/utils/iptables/Makefile
parent50d327196681f9514739355573e49db0ad151d6a (diff)
downloadupstream-d35a573004ff21e5a7bbdb896967454c63b7a363.tar.gz
upstream-d35a573004ff21e5a7bbdb896967454c63b7a363.tar.bz2
upstream-d35a573004ff21e5a7bbdb896967454c63b7a363.zip
iptables: make mod depend on libxtables
'iptables-mod-' can be used directly by firewall3, by iptables and by iptables-nft. They are not linked to iptables but to libxtables, so fix the dependencies to allow to remove iptables(-legacy) Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'package/network/utils/iptables/Makefile')
-rw-r--r--package/network/utils/iptables/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 12021c21f1..c5310838a3 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -41,7 +41,7 @@ endef
define Package/iptables/Module
$(call Package/iptables/Default)
- DEPENDS:=+iptables $(1)
+ DEPENDS:=+libxtables $(1)
endef
define Package/iptables
@@ -457,7 +457,6 @@ $(call Package/iptables/Default)
DEPENDS:=@IPV6 +kmod-ip6tables +iptables
CATEGORY:=Network
TITLE:=IPv6 firewall administration tool
- MENU:=1
ALTERNATIVES:=\
200:/usr/sbin/ip6tables:/usr/sbin/xtables-legacy-multi \
200:/usr/sbin/ip6tables-restore:/usr/sbin/xtables-legacy-multi \
@@ -485,7 +484,7 @@ endef
define Package/ip6tables-extra
$(call Package/iptables/Default)
- DEPENDS:=ip6tables +kmod-ip6tables-extra
+ DEPENDS:=+libxtables +kmod-ip6tables-extra
TITLE:=IPv6 header matching modules
endef
@@ -495,7 +494,7 @@ endef
define Package/ip6tables-mod-nat
$(call Package/iptables/Default)
- DEPENDS:=ip6tables +kmod-ipt-nat6
+ DEPENDS:=+libxtables +kmod-ipt-nat6
TITLE:=IPv6 NAT extensions
endef