aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables/Makefile
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-02-26 19:22:59 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-28 21:52:01 +0100
commit50d327196681f9514739355573e49db0ad151d6a (patch)
tree651fe40f6ee728e2ee04470d43ea7dc6a5176ddf /package/network/utils/iptables/Makefile
parentfb2801b82c06878ae2ad20b8f95546c34ed3cdf4 (diff)
downloadupstream-50d327196681f9514739355573e49db0ad151d6a.tar.gz
upstream-50d327196681f9514739355573e49db0ad151d6a.tar.bz2
upstream-50d327196681f9514739355573e49db0ad151d6a.zip
iptables: fix libnftnl/IPTABLES_NFTABLES dependency
libxtables doesn't depend on libnftnl, iptables-nft does, so move the dependency to not pull libnftnl with firewall3/iptables-legacy Also libxtables-nft depends on IPTABLES_NFTABLES Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'package/network/utils/iptables/Makefile')
-rw-r--r--package/network/utils/iptables/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index e936a57380..12021c21f1 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -112,7 +112,7 @@ endef
define Package/iptables-nft
$(call Package/iptables/Default)
TITLE:=IP firewall administration tool nft
- DEPENDS:=@IPTABLES_NFTABLES +libxtables-nft +libip4tc +IPV6:libip6tc +kmod-ipt-core +kmod-nft-compat
+ DEPENDS:=@IPTABLES_NFTABLES +libnftnl +libxtables-nft +libip4tc +IPV6:libip6tc +kmod-ipt-core +kmod-nft-compat
ALTERNATIVES:=\
300:/usr/sbin/iptables:/usr/sbin/xtables-nft-multi \
300:/usr/sbin/iptables-restore:/usr/sbin/xtables-nft-multi \
@@ -527,9 +527,7 @@ define Package/libxtables
CATEGORY:=Libraries
TITLE:=IPv4/IPv6 firewall - shared xtables library
ABI_VERSION:=12
- DEPENDS:= \
- +IPTABLES_CONNLABEL:libnetfilter-conntrack \
- +IPTABLES_NFTABLES:libnftnl
+ DEPENDS:=+IPTABLES_CONNLABEL:libnetfilter-conntrack
endef
define Package/libxtables-nft
@@ -538,7 +536,7 @@ define Package/libxtables-nft
CATEGORY:=Libraries
TITLE:=IPv4/IPv6 firewall - shared xtables nft library
ABI_VERSION:=12
- DEPENDS:=+libxtables
+ DEPENDS:=@IPTABLES_NFTABLES +libxtables
endef
TARGET_CPPFLAGS := \