aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables/Makefile
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-01-26 14:23:23 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-03 00:02:31 +0100
commit0e32c6baf37688e8cefed5718afe13ec18f75233 (patch)
tree6fc101b7c6c48287fabe3d64d964347efcfe844f /package/network/utils/iptables/Makefile
parent3a5df36cf694ca821ad5486ff360969bd3492aaa (diff)
downloadupstream-0e32c6baf37688e8cefed5718afe13ec18f75233.tar.gz
upstream-0e32c6baf37688e8cefed5718afe13ec18f75233.tar.bz2
upstream-0e32c6baf37688e8cefed5718afe13ec18f75233.zip
iptables: add ip{,6}tables-legacy{,-restore,-save} symlinks
Now that we can have both legacy and nft iptables variants installed at the same time, install the legacy symlinks Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'package/network/utils/iptables/Makefile')
-rw-r--r--package/network/utils/iptables/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index cf87d6de06..e936a57380 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -614,6 +614,7 @@ endef
define Package/iptables/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/xtables-legacy-multi $(1)/usr/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables-legacy{,-restore,-save} $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/lib/iptables
endef
@@ -626,6 +627,7 @@ endef
define Package/ip6tables/install
$(INSTALL_DIR) $(1)/usr/sbin
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-legacy{,-restore,-save} $(1)/usr/sbin/
endef
define Package/ip6tables-nft/install