aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables/Makefile
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2017-03-22 16:02:09 +0100
committerFelix Fietkau <nbd@nbd.name>2017-04-12 10:51:29 +0200
commit98e43b13a7f0f747d4625ba0209ba37ae22f3b48 (patch)
treeeb2b56e5aaf00e4427a2821ac86b5b4d9c177b51 /package/network/utils/iptables/Makefile
parentefb22b6f06d44bd156ea42d39779dabd356c7181 (diff)
downloadupstream-98e43b13a7f0f747d4625ba0209ba37ae22f3b48.tar.gz
upstream-98e43b13a7f0f747d4625ba0209ba37ae22f3b48.tar.bz2
upstream-98e43b13a7f0f747d4625ba0209ba37ae22f3b48.zip
iptables: bump to 1.6.1
Switch to git repo Removed musl patch Refreshed existing patch Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com> Signed-off-by: Felix Fietkau <nbd@nbd.name> [cleanup]
Diffstat (limited to 'package/network/utils/iptables/Makefile')
-rw-r--r--package/network/utils/iptables/Makefile36
1 files changed, 27 insertions, 9 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index ac869f0385..2fef0aba19 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -9,17 +9,16 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
-PKG_VERSION:=1.4.21
-PKG_RELEASE:=2
+PKG_VERSION:=1.6.1
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
- ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
- ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
- ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
-PKG_HASH:=52004c68021da9a599feed27f65defcfb22128f7da2c0531c0f75de0f479d3e0
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://git.netfilter.org/iptables
+PKG_SOURCE_VERSION:=7df66f1c13563cfbab75246b009ce36f69ee4487
+PKG_MIRROR_HASH:=22f15ef41fd8e3724bedcee666b7b6a3491d2d038d580ef1fb032718dcb73f14
PKG_FIXUP:=autoreconf
+
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPL-2.0
@@ -51,6 +50,20 @@ $(call Package/iptables/Default)
DEPENDS+= +kmod-ipt-core +libip4tc +IPV6:libip6tc +libxtables
endef
+define Package/iptables/config
+ config IPTABLES_CONNLABEL
+ bool "Enable Connlabel support"
+ default n
+ help
+ This enable connlabel support in iptables.
+
+ config IPTABLES_NFTABLES
+ bool "Enable Nftables support"
+ default n
+ help
+ This enable nftables support in iptables.
+endef
+
define Package/iptables/description
IP firewall administration tool.
@@ -413,6 +426,9 @@ define Package/libxtables
SECTION:=libs
CATEGORY:=Libraries
TITLE:=IPv4/IPv6 firewall - shared xtables library
+ DEPENDS:= \
+ +IPTABLES_CONNLABEL:libnetfilter-conntrack \
+ +IPTABLES_NFTABLES:libnfnetlink
endef
TARGET_CPPFLAGS := \
@@ -431,10 +447,12 @@ TARGET_LDFLAGS += \
CONFIGURE_ARGS += \
--enable-shared \
+ --enable-static \
--enable-devel \
--with-kernel="$(LINUX_DIR)/user_headers" \
--with-xtlibdir=/usr/lib/iptables \
- --enable-static \
+ $(if $(CONFIG_IPTABLES_CONNLABEL),,--disable-connlabel) \
+ $(if $(CONFIG_IPTABLES_NFTABLES),,--disable-nftables) \
$(if $(CONFIG_IPV6),,--disable-ipv6)
MAKE_FLAGS := \