aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-09-01 17:59:48 +0000
committerSteven Barth <cyrus@openwrt.org>2013-09-01 17:59:48 +0000
commit0a85c59040d6e053199962fe9127cc0d2d8febc3 (patch)
tree7ec8d32d10fe30056a402b5d4a1cd4a069435e35 /package/network/utils/iptables/Makefile
parent3e647ac9b6c432571c7969a6f25852443b6b2705 (diff)
downloadupstream-0a85c59040d6e053199962fe9127cc0d2d8febc3.tar.gz
upstream-0a85c59040d6e053199962fe9127cc0d2d8febc3.tar.bz2
upstream-0a85c59040d6e053199962fe9127cc0d2d8febc3.zip
netfilter: Add IPv6-NAT support for kernel and ipt Thanks to Berni, Adam Novak and Sedat Dilek for patches and inspiration
SVN-Revision: 37866
Diffstat (limited to 'package/network/utils/iptables/Makefile')
-rw-r--r--package/network/utils/iptables/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 879d786e8f..35dda06d9c 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -300,6 +300,17 @@ $(call Package/iptables/Default)
MENU:=1
endef
+
+define Package/ip6tables-mod-nat
+$(call Package/iptables/Default)
+ DEPENDS:=ip6tables +kmod-ipt-nat6
+ TITLE:=IPv6 NAT extensions
+endef
+
+define Package/ip6tables-mod-nat/description
+iptables extensions for IPv6-NAT targets.
+endef
+
define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
@@ -447,6 +458,7 @@ $(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
$(eval $(call BuildPackage,ip6tables))
+$(eval $(call BuildPlugin,ip6tables-mod-nat,$(IPT_NAT6-m)))
$(eval $(call BuildPackage,libiptc))
$(eval $(call BuildPackage,libip4tc))
$(eval $(call BuildPackage,libip6tc))