aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/ipset
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-09-25 05:55:27 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2017-09-25 22:52:46 +0300
commit7e58392bcbcf1b4711c967d93efec045d3c7eea2 (patch)
tree97acd82f8d79b1da6694e35cb06c9d3b495ebb94 /package/network/utils/ipset
parent592abe9ef53f921554d48085d6482d4507b3e142 (diff)
downloadupstream-7e58392bcbcf1b4711c967d93efec045d3c7eea2.tar.gz
upstream-7e58392bcbcf1b4711c967d93efec045d3c7eea2.tar.bz2
upstream-7e58392bcbcf1b4711c967d93efec045d3c7eea2.zip
ipset: bump to 6.34
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/network/utils/ipset')
-rw-r--r--package/network/utils/ipset/Makefile6
-rw-r--r--package/network/utils/ipset/patches/100-ipset-fix-build-with-musl.patch31
2 files changed, 34 insertions, 3 deletions
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index 66a9874055..55b7c493de 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
-PKG_VERSION:=6.32
-PKG_RELEASE:=2
+PKG_VERSION:=6.34
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
-PKG_HASH:=d9cbb49a4ae9e32d7808a604f1a37f359f9fc9064c210c4c5f35d629d49fb9fe
+PKG_HASH:=d70e831b670b7aa25dde81fd994d3a7ce0c0e801559a557105576df66cd8d680
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/ipset/patches/100-ipset-fix-build-with-musl.patch b/package/network/utils/ipset/patches/100-ipset-fix-build-with-musl.patch
new file mode 100644
index 0000000000..38377d698d
--- /dev/null
+++ b/package/network/utils/ipset/patches/100-ipset-fix-build-with-musl.patch
@@ -0,0 +1,31 @@
+From 992723e3712a09037338aa9e5506a080e24d1642 Mon Sep 17 00:00:00 2001
+From: Stijn Tintel <stijn@linux-ipv6.be>
+Date: Mon, 25 Sep 2017 08:09:01 +0300
+Subject: [PATCH] ipset: fix build with musl
+
+Include sys/types.h for u_int8_t and define _GNU_SOURCE for musl to
+expose it.
+
+Fixes: 54802b2c2826 ("Report if the option is supported by a newer kernel release")
+Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
+Signed-off-by: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
+---
+ src/ipset.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/ipset.c b/src/ipset.c
+index 79f56b8..8d70abc 100644
+--- a/src/ipset.c
++++ b/src/ipset.c
+@@ -14,6 +14,8 @@
+ #include <stdio.h> /* fprintf, fgets */
+ #include <stdlib.h> /* exit */
+ #include <string.h> /* str* */
++#define _GNU_SOURCE
++#include <sys/types.h> /* u_int8_t */
+
+ #include <config.h>
+
+--
+2.13.5
+