aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2017-10-01 21:46:27 +0200
committerHans Dedecker <dedeckeh@gmail.com>2017-10-13 21:48:44 +0200
commitdb18cee2d75d88e2ae88e3d1f75b5b3359ed6f19 (patch)
tree0c58790bbda4cfaeea8f85be90e7b18d104a0062 /package/network/utils/iproute2/patches
parent5bd006aa2689d1ec813936b13eb1eb85ef4a0ab8 (diff)
downloadupstream-db18cee2d75d88e2ae88e3d1f75b5b3359ed6f19.tar.gz
upstream-db18cee2d75d88e2ae88e3d1f75b5b3359ed6f19.tar.bz2
upstream-db18cee2d75d88e2ae88e3d1f75b5b3359ed6f19.zip
iproute2: bump to 4.13
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils/iproute2/patches')
-rw-r--r--package/network/utils/iproute2/patches/001-config.patch3
-rw-r--r--package/network/utils/iproute2/patches/004-darwin_fixes.patch2
-rw-r--r--package/network/utils/iproute2/patches/006-no_sctp.patch4
-rw-r--r--package/network/utils/iproute2/patches/008-no_netem.patch6
-rw-r--r--package/network/utils/iproute2/patches/110-extra-ccopts.patch2
-rw-r--r--package/network/utils/iproute2/patches/120-libnetlink-pic.patch4
-rw-r--r--package/network/utils/iproute2/patches/272-uapi-if_ether.h-prevent-redefinition-of-struct-ethhd.patch12
-rw-r--r--package/network/utils/iproute2/patches/300-ip_tiny.patch16
-rw-r--r--package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch2
-rw-r--r--package/network/utils/iproute2/patches/950-add-cake-to-tc.patch4
10 files changed, 21 insertions, 34 deletions
diff --git a/package/network/utils/iproute2/patches/001-config.patch b/package/network/utils/iproute2/patches/001-config.patch
index b3208e063e..7f23cfc35e 100644
--- a/package/network/utils/iproute2/patches/001-config.patch
+++ b/package/network/utils/iproute2/patches/001-config.patch
@@ -1,8 +1,7 @@
--- /dev/null
+++ b/Config
-@@ -0,0 +1,5 @@
+@@ -0,0 +1,4 @@
+# Fixed config to disable ATM support even if present on host system
+IP_CONFIG_SETNS:=y
+TC_CONFIG_ATM:=n
+TC_CONFIG_XT:=y
-+HAVE_MNL:=y
diff --git a/package/network/utils/iproute2/patches/004-darwin_fixes.patch b/package/network/utils/iproute2/patches/004-darwin_fixes.patch
index e1a5e97568..1f3eb101ea 100644
--- a/package/network/utils/iproute2/patches/004-darwin_fixes.patch
+++ b/package/network/utils/iproute2/patches/004-darwin_fixes.patch
@@ -42,7 +42,7 @@
#define TABLESIZE 16384
--- a/netem/paretonormal.c
+++ b/netem/paretonormal.c
-@@ -15,10 +15,13 @@
+@@ -14,10 +14,13 @@
#include <string.h>
#include <math.h>
#include <limits.h>
diff --git a/package/network/utils/iproute2/patches/006-no_sctp.patch b/package/network/utils/iproute2/patches/006-no_sctp.patch
index 0f6f269d40..e23fbcd77d 100644
--- a/package/network/utils/iproute2/patches/006-no_sctp.patch
+++ b/package/network/utils/iproute2/patches/006-no_sctp.patch
@@ -1,6 +1,6 @@
--- a/ip/ipxfrm.c
+++ b/ip/ipxfrm.c
-@@ -465,7 +465,6 @@ void xfrm_selector_print(struct xfrm_sel
+@@ -454,7 +454,6 @@ void xfrm_selector_print(struct xfrm_sel
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:
@@ -8,7 +8,7 @@
case IPPROTO_DCCP:
default: /* XXX */
if (sel->sport_mask)
-@@ -1321,7 +1320,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1329,7 +1328,6 @@ static int xfrm_selector_upspec_parse(st
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:
diff --git a/package/network/utils/iproute2/patches/008-no_netem.patch b/package/network/utils/iproute2/patches/008-no_netem.patch
index 47ffd9946d..64896387f9 100644
--- a/package/network/utils/iproute2/patches/008-no_netem.patch
+++ b/package/network/utils/iproute2/patches/008-no_netem.patch
@@ -1,11 +1,11 @@
--- a/Makefile
+++ b/Makefile
-@@ -52,7 +52,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
+@@ -49,7 +49,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
CFLAGS := $(WFLAGS) $(CCOPTS) -I../include $(DEFINES) $(CFLAGS)
YACCFLAGS = -d -t -v
--SUBDIRS=lib ip tc bridge misc netem genl tipc devlink man
-+SUBDIRS=lib ip tc bridge misc genl tipc devlink man
+-SUBDIRS=lib ip tc bridge misc netem genl tipc devlink rdma man
++SUBDIRS=lib ip tc bridge misc genl tipc devlink rdma man
LIBNETLINK=../lib/libnetlink.a ../lib/libutil.a
LDLIBS += $(LIBNETLINK)
diff --git a/package/network/utils/iproute2/patches/110-extra-ccopts.patch b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
index b28e19de57..e779934d72 100644
--- a/package/network/utils/iproute2/patches/110-extra-ccopts.patch
+++ b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -45,7 +45,7 @@ HOSTCC ?= $(CC)
+@@ -42,7 +42,7 @@ HOSTCC ?= $(CC)
DEFINES += -D_GNU_SOURCE
# Turn on transparent support for LFS
DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
diff --git a/package/network/utils/iproute2/patches/120-libnetlink-pic.patch b/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
index 1f397f71b2..ebe122e005 100644
--- a/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
+++ b/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
@@ -1,7 +1,7 @@
--- a/lib/Makefile
+++ b/lib/Makefile
-@@ -4,7 +4,7 @@ ifeq ($(IP_CONFIG_SETNS),y)
- CFLAGS += -DHAVE_SETNS
+@@ -12,7 +12,7 @@ ifeq ($(HAVE_MNL),y)
+ CFLAGS += -DHAVE_LIBMNL $(shell $(PKG_CONFIG) libmnl --cflags)
endif
-CFLAGS += -fPIC
diff --git a/package/network/utils/iproute2/patches/272-uapi-if_ether.h-prevent-redefinition-of-struct-ethhd.patch b/package/network/utils/iproute2/patches/272-uapi-if_ether.h-prevent-redefinition-of-struct-ethhd.patch
index 42e29326b9..c022d17126 100644
--- a/package/network/utils/iproute2/patches/272-uapi-if_ether.h-prevent-redefinition-of-struct-ethhd.patch
+++ b/package/network/utils/iproute2/patches/272-uapi-if_ether.h-prevent-redefinition-of-struct-ethhd.patch
@@ -65,15 +65,3 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
/* Definitions for in.h */
#define __UAPI_DEF_IN_ADDR 1
#define __UAPI_DEF_IN_IPPROTO 1
---- a/ip/iplink_bridge.c
-+++ b/ip/iplink_bridge.c
-@@ -14,8 +14,8 @@
- #include <string.h>
- #include <netinet/in.h>
- #include <linux/if_link.h>
--#include <linux/if_bridge.h>
- #include <netinet/ether.h>
-+#include <linux/if_bridge.h>
- #include <net/if.h>
-
- #include "rt_names.h"
diff --git a/package/network/utils/iproute2/patches/300-ip_tiny.patch b/package/network/utils/iproute2/patches/300-ip_tiny.patch
index e1b1da4d20..d48ea8581c 100644
--- a/package/network/utils/iproute2/patches/300-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/300-ip_tiny.patch
@@ -1,7 +1,7 @@
--- a/ip/Makefile
+++ b/ip/Makefile
-@@ -19,6 +19,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
- CFLAGS += -DHAVE_SETNS
+@@ -28,6 +28,13 @@ ifeq ($(HAVE_MNL),y)
+ LDLIBS += $(shell $(PKG_CONFIG) libmnl --libs)
endif
+STATIC_SYM_FILTER:=
@@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon
-@@ -48,7 +55,7 @@ else
+@@ -57,7 +64,7 @@ else
ip: static-syms.o
static-syms.o: static-syms.h
@@ -68,11 +68,11 @@
{ "netconf", do_ipnetconf },
+#endif
{ "vrf", do_ipvrf},
+ { "sr", do_seg6 },
{ "help", do_help },
- { 0 }
--- a/lib/utils.c
+++ b/lib/utils.c
-@@ -777,6 +777,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -787,6 +787,7 @@ const char *rt_addr_n2a_r(int af, int le
return inet_ntop(af, addr, buf, buflen);
case AF_MPLS:
return mpls_ntop(af, addr, buf, buflen);
@@ -80,7 +80,7 @@
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
-@@ -786,6 +787,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -796,6 +797,7 @@ const char *rt_addr_n2a_r(int af, int le
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}
@@ -90,8 +90,8 @@
default:
--- a/lib/Makefile
+++ b/lib/Makefile
-@@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
- CFLAGS += -DHAVE_SETNS
+@@ -12,6 +12,10 @@ ifeq ($(HAVE_MNL),y)
+ CFLAGS += -DHAVE_LIBMNL $(shell $(PKG_CONFIG) libmnl --cflags)
endif
+ifeq ($(IP_CONFIG_TINY),y)
diff --git a/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch b/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
index 44f198f1bf..a0fd154a57 100644
--- a/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
+++ b/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
@@ -24,7 +24,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
--- a/include/linux/rtnetlink.h
+++ b/include/linux/rtnetlink.h
-@@ -215,6 +215,7 @@ enum {
+@@ -220,6 +220,7 @@ enum {
RTN_THROW, /* Not in this table */
RTN_NAT, /* Translate this address */
RTN_XRESOLVE, /* Use external resolver */
diff --git a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
index 0705eb12c5..eacad074f1 100644
--- a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
+++ b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
@@ -1,6 +1,6 @@
--- a/include/linux/pkt_sched.h
+++ b/include/linux/pkt_sched.h
-@@ -863,4 +863,60 @@ struct tc_pie_xstats {
+@@ -871,4 +871,60 @@ struct tc_pie_xstats {
__u32 maxq; /* maximum queue size */
__u32 ecn_mark; /* packets marked with ecn*/
};
@@ -63,7 +63,7 @@
#endif
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -67,6 +67,7 @@ TCMODULES += q_codel.o
+@@ -69,6 +69,7 @@ TCMODULES += q_codel.o
TCMODULES += q_fq_codel.o
TCMODULES += q_fq.o
TCMODULES += q_pie.o